Samsung tablet, APM and Bluetooth Issue

I have connected successfully my APM to my Samsung tablet this way:

(copter side) APM>Telemetry port>HC-06 BT Module --//–> (tablet side) BT>MavlinkHub>Droidplanner.

My problem is, after connection is established, Droidplanner shows the Armed/Disarmed status of the APM. I can also Arm/Disarm from Droidplanner on the tablet (the motors start at slow speed).

But no data from the APM are shown, not the inclination, speed, height, fix… nothing.

This is strange and I could not fix this issue so far :confused:

Any help would be apreciated! Thanks in advance


Hello Forum,

this is my first Post in this Forum and I have exactly the same Problem as Genoacopter above.

Please Forum, could you help us?

My Android Device is an Samsung Galaxy Note 10.1 (Wifi only)

kind regards

I solved the problem, and I hope this can help other people.
When I did the first tests, I had the BT module connected to the APM board with long, clumsy wires and the voltage divider resistor soldered on the RX line of the BT module. And I had the data trasfer problem I described.
Then I got rid of the messy wiring, shortened the cables and eliminated the resistors.
Now it works LOVELY, and transfers all data :sunglasses:
My advice is: don’t use the the voltage divider (in this application) and make a proper wiring, also considering the transfer speed.

Have fun