Same PC, same FC model, same firmware. No heartbeat on MP, QGC connects with no issue

Hello to the greatest developers who usually not answering any complex questions here.

I have a “No Heartbeat Packets Received” problem when connecting via USB.
My hardware is CUAV V6X Arduplane 4.4.0.
Windows 10/MP 1.3.80 build 1.3.8693.15776

What I tried:
Restart the FC - nothing
Restart MP - nothing
Restart the PC - nothing
Tried Stable MP - nothing
Tried Auto Connection - nothing
Tried to upgrade/downgrade FC FW - upgraded, nothing changed
Tried to install PX4 and reinstall AP - done, nothing changed
Tried to change COM number in Device Manager - nothing
Tried to clear MP XML config file (COM port params) - nothing

Tried to connect with QGroundControl - connected OK
Tried connect to another laptop - connected OK

Tried to connect another same V6X with same firmware to MP on my workstation - connected OK
Tried another FC - HolyBro PX 6C - connected OK

That’s where my ingenuity ended. I cannot connect a particular flight controller to the Mission Planner on a particular PC.

Maybe the best in the world development team which for 10 years cannot achieve the same simplicity in the connection process as open source QGroundControl firmware can offer…
…can suggest something to me, the 3 year Ardupilot fan who is facing major issues?

  1. being sarcastic will not help.

Just to see if I understand correctly

You have a V6X(1) and workstation(1)

V6X(1) on ws(1) does not connect to Mission Planner
V6X(1) on ws(1) does connect to QGCS
V6X(1) on another computer does connect to Mission Planner

Another V6X with the same 4.4.0fw on ws(1) does connect to Mission Planner

Mostly correctly.

I have a V6X(1) 4.4.0, V6X(2)4.4.0 and workstation(1) (to clarify I tried different FW ver. on both FC)

V6X(1) on ws(1) does not connect to Mission Planner (Stable or Beta, different FC FW Latest/Dev/old)
V6X(1) on ws(1) does connect to Mission Planner in “Install Firmware” process
V6X(1) on ws(1) does connect to QGCS
V6X(1) on another computer does connect to Mission Planner and works fine

V6X(2) on ws(1) does connect to Mission Planner
Another V6X (I meant V6X(2)) with the same 4.4.0fw on ws(1) does connect to Mission Planner

Let’s do a driver cleanup.
Go to device manager, select show hidden devices from the View menu.
Go through all Serial ports and right click uninstall.
When done, start Mission Planner, press CTRL+F select driver cleanup.
exit mission plannr.
Download and run
If it recommend repair, then do uninstall and then start again an install.
try connect.

Thank you for suggestion but nothing changed.
The COM port numbers become different but still no connection.

Thats funny that I installed PX4 FW and Mission Planner successfully connected to the FC but I need Ardupilot, not the PX4

It does not makes head or tail… Could you check the USB ID’s of the two V6X plugged to the wrong workstation ?

Also in that screenshot at top right you have 1500000 selected as the baud rate.
Can you check with 115200

All the flight controllers have 115200 as the default USB baud rate, even though some may be capable of more. You would have needed to change this parameter in the flight controller: SERIAL0_BAUD,115

As far I see - the ID’s are same.

Upper - V6X(1) that not connecting.
Bottom - V6X(2) that connects fine.

Sorry, I forgot to mention in initial post.
I tried different Baud Rate - 9.6/19.2/57/115/MAX - nothing.

Did you tried port 29 instead of 49 ?

Yes, of course - no connection. V6X should connect on both ports.

Well, it should not. One port is Mavlink the other one supposed to be SLCAN.

But honestly I ran out of ideas. I still believe that this is a driver issue, which somehow affects serial comm in .net framework, since QGCS uses it’s own serial library it is not affected.

This would normally fix any issue. Throw in a reboot after uninstalling all those hidden devices…

Actually no. At least on default settings.
I have five or so V6X and all behave the same - first and second COM works as MavLink. Also I tried HolyBro Pixhawk 6C - same behave. Even, as far as I remember, HolyBro Pixhawk 4 works same way. All them shows with no SLCAN. That was tested over the last year with different FW Ver. and different WS.

Only Matek H743 shows/works as MavLink on first and SLCAN on second COM.
And maybe some others FC but I did not test or not remember that.

Can you suggest me how to properly clean install .net or so? Lets try, maybe it will help.
And in part of bad driver - IDK… The HW IDs are same so logically speaking just changing the COM number here should fix the problem