Servers by jDrones

Safety Arm Switch Press is not detecting

Hi All,
I reassembled my hexa-copter after a crash.
My vehicle configuration is,

  • ArduCopter 3.6.7
  • Pixhawk2.1 with cube black
  • Here2 GPS

During the testing I found that Pixhawk2.1 is not detecting the Safety Arm Switch press for arming the vehicle. I tried another GPS module, still no luck. Then I tried same GPS in another Pixhawk2.1 in which the press is detecting and Red LED is changing from flashing to solid.
I checked he voltage at GPS connector and found 0V without pressing the switch and 3.3V while pressing the switch. Later I checked the continuity from GPS connector from the carry board to the STM32 pin inside the Cube. Electrical continuity is coming. I even tried re-programming the code, but still it is not detecting.

Is there any other troubleshoot mechanism to check why Pixhawk is not detecting the Safety arm switch press?
I did one flight test by disabling the " BRD_SAFETYENABLE" parameter, everything is okay.

Good day,
Did you try restore with a flash the firmware of your gps module?

Hi @Dave84 ,
I tried the same GPS in another Pixhawk2.1 and is working perfectly.
What I understood is Safety switch is just a analog signal to the STM32 from the GPS module.

Thanks

if work in another cube must work also in the other one… check the settings

Hi @Dave84,
Thanks for your suggestions.
The same system, Pixhawk & GPS combo, was working perfectly before crashing. I have not changed any settings (I’ll verify that again on Monday).
My doubt is, will the STM32F101/103 analog pin (pin 41, PB5) go bad due to any reason? During the last crash, GPS cables got damaged and I noticed that safety switch wire got cut.

Thanks.

For check the pins of your board you need to open the case of your fc… without a pic it’s impossible to say if the crash have damage the board… the co processor or the pins

@Dave84, as i mentioned in the first thread, I have physically checked the connection from GPS port to STM32 pin 41 by checking the continuity. All tracks are electrically good.
Also I checked the voltage at GPS port after connecting the GPS, it seems to me okay.

What I meant is, is there a possibility that something inside the processor going bad?

i don’t know what kind of crash you have encountered with your drone,. if you have damage the MCU or the FMU maybe you can change it and reflash it as was before… but i will not use that board for fly again

@Dave84 Thanks for the suggestion. The crash was mainly due to the low battery voltage and our fail-safe was set to land and it landed over a tree and then fell down.
Let me re-flash and check the the Pixhawk again. We have flown after the repair and flying is seems to be okay, unless the safety switch issue.

Thanks

Servers by jDrones