Sabre Crash on Autotune Uncontrolable Throtle

Hello friends:
I am writing to please help me solve the mystery of this cruel accident. On the opening flight of my SABRE UAV in the Autotune process I suddenly lose control of the plane which accelerates brutally and turns to the right. I lose total control of the plane no servo responds and finally crashes.

I flew with a Pixhawk, 4S 4500 800KV Engine 11x6 Pusher. Inmersion R / C long range installed on a Taranys 9XD
Before that the plane flies well for about 4 minutes.

I enclose the Pixhawk log for review and comments.

Thanks in advance.

I am no plane expert but it appears you had a failure of some sort mechanically.
Your power output goes to max, battery voltage drops, and the vibrations rise dramatically.
Looking at the RCout both the pitch and roll are maxing out each way, especially the pitch.
Could you have lost the elevator linkage in flight or similar?
Your vibes peak out at the end as well, maybe flutter?

Hi Mike
Thanks for your quick response. After the accident I was able to retrieve the plane almost completely. I did not find evidence of mechanical problems in the elevator. Neither in the ailerons.

There were vibrations right after I lost control but I do not know why they were generated.

I was able to retrieve a gopro camera that recorded the entire flight.

Here is a link to the video for you to see.

https://youtu.be/8jO86cuAorM

Listening to the audio in the video, along with the RCout in the logs, I still pin my best guess on mechanical failure.

You were really pushing that little foamy around the sky at a fair rate.

Hi Mike:

How to explain then that the throtle went crazy ?. The throtle has nothing mechanic that left it locked.

The elevator also rises and falls without any relation to the signal that is entering

Why is there a failsafe right before it goes crazy?

Hi, I am no expert in this but, but after RTL started your plane nose up as expected to reach target altitude of 100 m(ALT_HOLD_RTL).

However, in the picture above, after 10 seconds it seems that autopilot somehow gave a nose down command, even though RCin CH2 stays constant. I checked the TECS parameters as well but could not make any sense.

Hi,

you have set ARSPD_ENABLE = 1 and ARSPD_USE = 1 but your airspeed in the log is not working (values between 0 +/- 1 m/s). Maybe when RTL was activated the plane try to gain airspeed but because of the faulty sensor (did you have an airspeed sensor in your plane?) it was not possible (max throttle). Maybe than it is pitching down to get more airspeed.

Regards
Mirko

1 Like

Hi Mirko

I think that may be a possible cause. The plane had an airspeed sensor. I did not check if it was working or not before take-off.

I’m not an expert either. Is it possible for pixhawk to react in this way to the error of the air speed sensor?

There is this setting :
http://ardupilot.org/plane/docs/parameters.html#ahrs-wind-max-maximum-wind

I set it to 13

AHRS_WIND_MAX: Maximum wind
Note: This parameter is for advanced users

This sets the maximum allowable difference between ground speed and airspeed. This allows the plane to cope with a failing airspeed sensor. A value of zero means to use the airspeed as is.
Range Increment Units
0 - 127 1 meters per second

Hello, thank you very much for your comment.
As I commented to Mirko I think the crash might have been due to the problem of the air speed sensor, however, I have no clue that cause the F/S in the first place.

The plane was not more than 100 m from where I launched it and also had a UHF receiver. The telemetry is also lost and this was transmitted by another antenna in the 900 Mhz.

What triggered the whole problem?

I just answer if pixhawk could handle a bad or failing airspeed sensor …

Thanks. You are pointing me in the right direction.

I just want to understand what happens to not repeat the same mistake

FS_GCS_ENABL is set to 1 = Heartbeat
FS_LONG_ACTN is set to 1 = RTL
FS_LONG_TIMEOUT is set to 10 seconds

It seems that there was no GCS heartbeat received for more than 10 seconds which switch the flightmode to RTL. You can change FS_LONG_ACTN take a look at http://ardupilot.org/plane/docs/parameters.html#fs-long-actn-long-failsafe-action or FS_GCS_ENABL http://ardupilot.org/plane/docs/parameters.html#fs-gcs-enabl-gcs-failsafe-enable .