S900 E1200 PH2 -Wobbles- (like glitch response) problem


I’m having an strange issue with PH2 and S900 upgraded with E1200 motors.

The problem is that sometimes, hardly ever, I have really strong oscilations of the frame, clearly visible vibrations at the frame and arms, like wobbles.

The configuration is: s900 frame, e1200 motors with their arms, latest firmware, ±౩° at each motor like standard dji s900 arms, PH2 sticked at the center of plastic cover for the ESC plugs with white 4 mm foam provided within the PH box latest stable firmware too and latest stable version of mission planner too to adjust and configure, power module connected at one of the yellow xt60 empty plugs at the top of s900 frame, only to power PH, not at the middle of power line. Taranis and x8r rx, mounted at left side of the frame, buzzer at the back of the frame, safety switch at the other side of the rx, led+usb and i2c hub, gps at the top front of the frame, 15 cm over the main frame, galaxy gbs parachute over the top cover of the frame, centered, 16000mAh gensace battery mounted nearer the center place possible leaving 10mm to the bottom xt60 plug, 3 dampers at each side of battery/gimbal mount, 6 black ones at the battery side, 6 gray ones at the front side where a asp 2 axis is atrached (I’ve also tried with 2 dampers at each side), I’ve also tried hard motor dumpers and motors directly screwed to the motor mounts (old and new version of e1200 motors?) and I think that’s all.

I have been adjusting PID’s, checking correct strength of the propellers, calibrated ESC range, done auto tune flights successfully, checked the good balance of weights and G.C. updated FW of PH2, downgraded it too, updated again, re-flashed with rover and again with copter, but I still have this issue.

Today, this morning I did a test flight to start checking and doing more tests.Looking for procedures, coincidences, connections…
First flight has been flying perfectly, without any strange behaviour.

After that flight I have landed and reconnected the battery. It has started to fly really bad again. like it had some lag anywhere and moves like a robotic movement of a robot.

The strange thing is that only rebooting the power (only disconnecting red power cable of the battery, without moving, touching or adjusting anything else), sometimes flies really well, and other times not.

I can’t told which adjustment or procedure works correctly because at this time, I couldn’t repeat any procedure two times with good result.

Maybe it can be relevant, but the strange thing to me is that one boot it flies perfectly, and only rebooting the PH (meaning disconnecting and connecting again main batetery), without moving or touching enithing else, it swaps to a perfect flight to a erratic flight.

Is anyone experiencing that bad and aleatory response of the PH2?
Is anyone having problems with that E1200 motors used with PH?
Is anyone working well with that build?
Has anyone any idea about what can be happening?
Thank you very much in advance!

Log files: https://www.myairbridge.com/es/#!/download/package/UMMXWIGSS2JVN2GA

There was a question raised about your motor order at the RC out pins, and the lack of ground pins to your rail…

Motor order of the pins is because the Critical service bulletin for Beta Cube 2.1.

I’ll try new setup with ground pins connected in all ESC’s


Check the motor order on the ArduPilot docs. It’s NOT the same as DJI (it must be correct otherwise a crash was certain)

Also get a good Power module (6S) and get it correctly on the wires from the battery to the S900 PDB. ArduPilot can do some neat things if the current is measured

Check your Voltage Failsafe.

1 Like

Hm…somewhere, i think i read something about how DJI ESC limit current of ESC to 30A…i don’t know if this is relevant…
Also,you can try old trick with connecting + and - (red and black on your PDB)before changing LiPo
Also,please give us some photo…you know how they say;one picture 1000 words…i could add;one video-1000 pictures…
This guy also have problems with S1000 maybe you can help each another by comparing data

S900 with E1200Pro is a completely different beast of the regular S900 and from the S1000

All fly very well, even on default settings, but require some tuning, that can be done with one or two batteries of flight time.

I have been doing some testing and changes and I wanted to try some things before explaining these.

The problem is still remaining.

The copter flies, turns and moves to the sides correctly. The motor order and crossing numbers from motor 1-6 from PH are well done to 1-6 motors at S900 frame.

After doing autotune with this frame, values are the next:

I have put these same values to other frames (apparently build the same way) I have build, and these others flies really well.

The changes I’ve done, after some proposals at FB post are:
I have put all ground wires to all signal cables to the ESC’s, each ground correspond at his signal wires, meaning the mix between PH motor order and frame motor order is the same in signal cables and ground cables.
I will leave these cables as you recommended to have a straight 0 reference, anyway, this changed didn’t solved the issue.

After that I tried to set the MOT_PWM_MIN (1120) and MOT_PWM_MAX(1920).
Apparently It didn’t changed anything else. In fact this change has produced the motors to start spinning when pressing safety switch, with copter disarmed. So I went back and leaved “0” value at both parameters.

I’ve also checked the good alignment of compasses, and re-calibrated compass. Still having same problem.

After that, I remembered that one time I had some problems with one Taranis and one X8R rx, so I used a new RX and a transmitter which is working well with other S900 and E1200 and PH2.
That neither solved the problem, so, I put again the first RX and TX.

There come some photos

The only difference of the photos and how is that now is there are also ground wire cables at motor outs.

I’m also attaching a video showing how it flies. Wobbles problem seems to be solved with the autotune, but it’s still having some “ticks” like short glitches in his attitude.

Here comes the video showing the flight. It’s in low speed so I’ll try to accelerate it to make it more visible than in slow motion.
S900 E1200

It’s all the time making this erratic movement, at the end of the video is when it’s more appreciable.

When I move motor channel 1 to channel 7, following the instructions of critical service bulletin, there are some values that maybe affects?
RC7_MAX value is 1900
RC7_MIN value is 1100
Should I have to change these values to some others to be the same for all motor outs? Does that make any sense?

Attached is the last flight log. At the end of the flight there is the bigger example of this issue.
2017-03-21 17-38-32.bin (1.1 MB)

I have been reviewing the different values of the logs but I don’t know what else can I check to found the mistake.

Thank you!

Hi Matt,
I think I have the same issue with my Pixracer Quattro with E1200 motors.
Did you managed to solve the problem?


Hi Haydar,

I’m not sure if it could be the same problem as ours. We get a full batch of faulty parachute cutoff systems. After replacing it, it performed well.


Thanks for the answer, Matt
In my case, PID tuning was the problem.