Servers by jDrones

S ervos hanging/freezing on Ardupilot - Savox SG0211MG

Hey. I got a problem with servos hanging/freezing on Ardupilot. It looks like the servos themselves are the problem. They are Savox SG0211MG - I’ve read about many problems with Savox. The problem looks like this:


The autopilot (Cubepilot Orange) is powered from main battery. The servo rail is powered via 5v3A BEC (integrated with ESC). I’m on arduplane 4.0.7, there are 4 elevon servos on the model. I’m using Crossfire as RC link. I’ve tested them in every possible mode - always the same result.
I’ve tried everything:
  1. changing the SERVO_RATE to 240,
  2. changing BRD_PWM_VOLT_SEL to 5v
  3. plugging in separate 7,2v battery to power servo rail (instead of BEC)
  4. using 5000 uf low ESR capacitor
  5. I’ve checked if the problem exist with only one servo plugged in into the servo rail (yes it still exists)
    It’s not RC link problem, and I doubt it’s an autopilot problem (checked on two different Cubepilots). Looks like those servos are crap, or are super power hungry.
  6. I’ve check them on 5v and 7,2v. - always the same, bad result.
    Can You help me ? I literally don’t know what to do next
Servers by jDrones