RxRSSI and chXin HUD items and Status items not working

I’m currently using Arduplane 4.0.8 on a Cube Black and had previously had RxRSSI working on the HUD (not sure which versions of Arduplane or Mission Planner unfortunately).

RxRSSI is logged correctly in the data flash logs.

Lately it has not been working, and I note that the fields in the status tab are not working either, nor are they in quick view if you enable them. The same issues also seem to affect chXin and chXout.

I noticed that SR1_RC_CHAN is set to zero. (Modem is on Telem 1 which I believe to be affected by SR1_xxx?) I tried setting this to 2 as I thought that it might fix the issue. However, this reverts to zero on reboot. I gather from other posts that this may be changed by Mission Planner? I’m also not sure whether it is the cause of the issue.

I have tried Mission Planner 1.3.75 and 1.3.76, with the same behaviour.

I really need to have RxRSSI displayed for safety monitoring reasons.

you missed to tell only the most important thing. what kind of telemetry are you using ?

Haha, oops! The telemetry is MavLink over

Many thanks.

Hi Just, to update this, I see the same issue when connecting with USB as over telemetry!

Ok, so I figured this out in the end! In Mission Planner, under Config > Planner there is a setting for telemetry rate for RC. Setting this to something other than zero makes the RSSI report start working!

indeed, you must have changed it to 0, as 0 is definitly not the default.

0 = dont request messages, for those advanced users