Servers by jDrones

RX4R RSSI stuck at 1966 uSec

I’m setting up a PX4-mini with an FrSky RX4R. Most of the setup works, but the RSSI is stuck on 1966. I bound the RX4R so it outputs RSSI on channel 16, and there’s a value that comes out, but the value is always 1966 regardless of how far the TX is.


rssi

Hi,
What are the Mixer settings for channel 16 on your TX?

You should have a mixer RSSI -> Chn16 in your TX
weight 200%
offset -100%

There are no mixer settings for Ch16 on the TX. I don’t want to send anything from the TX on this channel. I want the receiver to output its idea of RSSI on this channel.

Longer answer: the TX (Taranis) sends channels 1-9. I use the same TX memory for all my ArduPlane aircraft. I have five with R-XSR or XM+ receivers, and they all work as expected with this setup. On this airframe, I’m using an RX4R I had lying around, and I’m trying to set it up the same as all my other setups. The only independent variable between setups that work and this one is the RX.

Ari.

As far as I know for the the XM+ (non telemetry) receiver there is a RX firmware available which outputs RSSI on channel 8 or 16.

For the Frsky telemetry receivers like R-XSR or the RX4R or other X-series receivers I have set a mixer as mentioned above. Works for me on the (old) ACCST-D16-protocol.

Do you run the newer ACCESS protocol with channel mapping on the RX side available? Otherwise I can’t see the link between RSSI and channel 16.

This is in the stock firmware for all of these receivers:

Cool, I wasn’t aware about this feature. I always made the connection as described above.

Would be even better if the RSSI output worked as promised.

Well, the same issue with R-X6R with old ACCST D16 firmware 180516(pre 2.x.x).
In passthrough mode, I can easily impact the CH16 value from the radio.
But when I’m switching CH16 to RSSI mode it immediately changes the value to 1966 and no matter what happens it stays as it is.
@iter could you please share firmware versions of your transmitter and receiver?

The receivers are stock. TX is 2.2, although this makes no difference. I’m not sending anything on channel 16.

@iter I’m not really sure what does it mean “2.2”, is it the OpenTX version?

But anyway, good news… I took a deep breath and updated everything(built-in XJT module and receiver) to versions 2.x.x(2.1.0 and 2.1.1 correspondingly). After that RSSI reporting started to work. So my guess is that it is an old firmware issue.
Most probably your stock firmware in a receiver is “pre 2.x.x” thus it has a similar issue to mine one.

The bad news is that now I need to upgrade ~10 receivers to version 2.x.x and still not sure if 3rd party receivers will work.

Yes, OpenTX. Is the RX firmware update incompatible with stock firmware?

Well, the version of OpenTX is not really important in that context (but still it is better to have a newer one than older :D).
What is important - the firmware version of your built-in RF module (for instance in FrSky X9D & QX7 it is called XJT) and also the receiver firmware version.

Also experimenting a little bit I figured out that the value 1966 means “no rf link exists”

Servers by jDrones