Servers by jDrones

RX RSSI not being displayed properly


(Henry Wurzburg aka ATX_HELI) #1

Using Arduplane daily build for OmnibusF4Pro.

RX RSSI is analog from RX and displays properly in OSD, via telem port in Mission Planner and Tower, but not in QGC Android version

it states RSSI not avaliable when TX is on, and bounces noisily at 10-20% when TX is off…

OSD/MP, etc. indicates properly…ie 95-100% when TX is on, and 1-5% when TX is off…


(basti) #2

@Noircogi referenced this fix on RCG recently: https://github.com/mavlink/qgroundcontrol/pull/6634

afaik last release for mobile devices is 3.2 though.

basti.


(DonLakeFlyer) #3

Latest Android stable build is 3.4. The RSSI fix for ArduPilot is in Daily Builds which are also available for Android.


(basti) #4

thanks @DonLakeFlyer
i was looking at the android download pages‘ release notes saying 3.2, while additional info‘s version points to 3.4 really.
iPhone version seems to be 3.2 though. any chance there‘ll be updates for the iPhone version?

thanks, basti.


(DonLakeFlyer) #5

Ah, the android store listing was out of date. I changed it with a link to the release notes intead of including directly. I’ll look at what’s going on with Apple store version. That should be 3.4 as well.


(basti) #6

@DonLakeFlyer any news on apple store version? i guess quite a few users (incl. myself) would really appreciate running current QGC versions on their IPhones.

cheers, basti.


(DonLakeFlyer) #7

I’ve been fighting with it. New store needs a privacy policy statement which is in the works. After that I should be able to push one up I hope.


(basti) #8

great news, thanks a lot @DonLakeFlyer !


(DonLakeFlyer) #9

Stable 3.4.3 is in the apple store now.


(basti) #10

thanks a lot @DonLakeFlyer !


(basti) #11

@DonLakeFlyer having tried the updated version from apple store i noticed RC RSSI from ardupilot still not being available, which kind of brings this back on topic. likely the current apple-store version 3.4.3 of sept 2018 does not contain the respective fix https://github.com/mavlink/qgroundcontrol/commit/ad4bd5c of late nov 2018. so thanks again for your efforts, staying tuned for future releases!

basti.


(DonLakeFlyer) #12

iOS version has been updated to the latest stable