Runtime error on Cygwin when trying to run ArduPilot SITL

I’ve tried to setup SITL by following the instructions from this link:

However, when I run the following command:
cd ~/ardupilot/ArduCopter
…/Tools/autotest/ --map --console

I get the following error:

Is there a change I have to make to one of the files?

You’ve not installed git in Cygwin.

From your screenshot, you’re instead using the Windows git, which won’t work properly in Cygwin.

Thank you for the reply. I went back to the cygwin installer to make sure that the git file was installed, and it was, but it seemed like some of the installed files might’ve been corrupted so I re-installed them. Now as I try to run the ‘pip install empy pyserial pymavlink’ command, the app freezes while running the setup oy.install for lmxl. What do I do?

You need to install lxml in the Cygwin setup. Look for a python36-libxml2. There’s a whole list of required packages over at

I actually installed all those files again, just seemed to be multiple instances of them for some reason so I re installed the whole thing again, everything works alright now. Thanks!