Running PulsedLight LIDAR-lite Off of Pixhawk Servo Rail

Hello, I am recently purchased a LIDAR and I am trying to incorporate it into my Pixhawk. The problem is when I power on the Pixhawk I don’t get any LIDAR data in my flight data. sonarrange and sonarvoltage both read 0. I am trying to run the LIDAR off of the Pixhawk’s servo rail. I followed all of the instructions here Attached is also a wiring diagram of my set up.

Am I missing some obvious crucial step? I don’t need to provide external power to the servo rail do I? Shouldn’t the pixhawk just supply power to the rail if the battery is hooked up? I can drive the motors fine in this set-up.

Hey Ford,

Sorry, I’m a little confused with your setup.

You should be receiving power to the servo rail from the ESC’s BEC via the throttle servo lead. The pixhawk will not power the servo rail from it’s connection to the power module. You need to power the servo rail from the ESC BEC, or elsewhere.

Does this help?

Didn’t even look at the picture first (and I’m a fixed wing guy). You’re only connecting the signal wires from your PDB and not powering the rail. Add a 5v BEC to power the rail.

I tried doing that originally, and still got no response. I can try again. Do you know offhand which pin on the Pixhawk to connect that to? I think the documentation said any pin between 1-8

Did you connect the + and - from the bed? Any pin, just make sure you have the polarity correct. Do you have a multimeter? Use a servo extension to verify that you’re powering the rail with your bec, and continue troubleshooting after verifying that you are getting voltage. Also, will the lidar run on 4.5v, out of curiosity?

Ok, I will try again. I think last time I probed the rail I wasn’t getting any voltage on the servo rail. I’ll try again. And yeah, the LIDAR is designed to be able to be run off the servo rail.

Alright. After some probing I determined the power board I was using worked differently than thought. I now have it wired, and can confirm that the servo rails are getting 5V of power…but I am still not getting any readings from my LIDAR. I did a continuity check of the wiring of my LIDAR and everything is wired as it should be. So I’m stumped. Is there something special I have to do in MissionPlanner to turn on the LIDAR?

Go Back to the Wiki for MP setup directions:

You then need the following parameters set to enable the PWM driver:

The use of pin 55 as the stop pin is just a suggestion, not a requirement. It connects to the enable pin on the Lidar, and allows the driver to reset the Lidar if it stops providing readings.

The use of pin 54 for the PWM signal is required, and only FMU AUX5 (pin 54) can be used due to the internal timer routing of the Pixhawk.

I did all that already, and still nothing

This Video clinched it for me: …

Joe have you used this LIDAR before and gotten it to work? Because I’ve followed all those steps in the video. What version of MP are you using? And AC?

I always update to the newest APM Code (3.3?) and MP when prompted. I got the LIDARLite working fine following the video. There are a couple of hard to find ‘Sonar Switches’ that you have to trigger to enable in MP, and I wish there was a power LED on the Lidar. I power directly from a BEC.

Be aware that when your MR tilts forward in flight it will drop, because the geometry to the ground changes. I mounted the Lidar tilted forward to sense the terrain in front of me, so I really dropped when in reverse.

I haven’t been brave enough to fly Lidar over a still pond yet. What happens when the light beam reflects into space at an angle and the sensor gets no feedback? Does my MR descend into the water looking for a relfection?

Lidar does not work in Auto flight mode, yet; so I’ve moved on.

Dear Ford,

I had that problem before with Serial Connection using my SF30 LiDAR. I solved using the Lightware Terminal how I show in the pic. The BaudRate was the problem because in the Full Parameter List we set 19200 in SERIAL4_BAUD.
Let me know if that help you because it didn’t help me hahaha. However, I’ve tried in Analog Connection and really works. :grin: