Runaway drone, what went wrong?

Hi guys!
I lost control of my drone just after take off. I had some influence on the rudders but I not the throttle. I felt that I had best control in sport mode, until some voilent manouvers happened. I tried to turn off radio several times hoping to failsafe to kick inn. No luck with this. The crash ended with more luck for me than I deserve. Still scary experience. I trying to understand what happened.

Heres youtube from the trip:
I have logs from drone in case anybody would be so kind and look at them (where to upload the files, and what files to upload?)


You should upload , .bin , dataflash log , if it has a small size you can uploaded it here , if not in whatever storage service .

I have look to your video, first, your esc seems to me, from the motors sound , having different calibrations so I expect to see a huge amount of vibrations.
The vibrations can have confuse the Auto Pilot and lead to weird behavior.

I think you have lost completely your radio, probably you have the failsafe set on the receiver that continues to send last frame to the Auto Pilot, at 4.56 you can see that CH3 is completely low while motors are running so the radio in in not ok.

That are just speculations until you will post the .bin file.

You took off with no Home Position Set, the motors are screaming, like you have too much motor and not enough prop, the aircraft is shaking all over the place because the PIDs are WAY out of tune… I’m surprised it stayed in the air as long as it did.
With that said we need a complete hardware list, motors, props, batteries, ACCURATE aircraft weight with every thing installed INCLUDING THE BATTERY.

Hi guys! I zipped 2018-05-27 10-42-24.bin and 2018-05-27 10-42-24.log.param to this file

I purchased the drone second hand and it was flying fine on Arducopter 3.4. I upgraded it to 3.5 and adjusted gimbal settings + some other stuff. I’m new to arducopter so everything is new to me, but I have some experience with racing drones and DJI F550. I’m not sure how it was on 3.4 but on 3.5 when I was trying the drone without props, I think the motors were behaving quite strange. On racing drones when you arm it and move it around the motors are spinning in a intuitive way according which way you tilt it. The respons is instant. I had response on Arducopter 3.5, but the response was sluggish and not precise.
Same with radio reponse. I could see quite fast response in Mission Planner, but response from motors felt delayed.
I started to work on ESC settings and changed from Normal to Oneshot. I tried Oneshot 125 but there was no response from motors, so I switched back to Oneshot. I adjusted idle speed and min speed according to what I found in manual. This felt OK.
As you have noticed the drone was shaking on takeoff and this didn’t feel right. I thought it was because of turbulence so I pushed throttle a little more, until it got in the air. I tried to do this gently, and on my 3rd. try it lifted off. The second it launched I lost control with throttle.

In video I tried to fly with throttle way back and I tried to switch flight modes, I had some reponse but nothing I felt I could keep under control. Some times you see RSSI to 0, it’s when I turned the radio off, hoping the failsafe to kick inn. Failsafe was working OK when I tested drone w/o props, turning radio off. At least the drone stopped motors and disarmed.

The arducopter seems much more advanced than the stuff I am used to. It seems like the drone is aware then it’s in the air and when it’s not. I tried to lift litt off table when I armed motors, but I don’t know if I managed to fool the drone to think it was flying.

Hardware of the drone is: Luminier QAV-400, 3DR Pixhawk, 3-axis gimbal - Zhiyun Z1 TINY 2, ESCs - TBS bulletproof 30A, T-Motor MT2212 1100KV, Graupner Sport Prop 8x4,5, Mauch Electronics Volt/amp-sensor, PlayUAVOSD , Drotek FR GPS, 4S 4000 MAh, Taranis Plus, UHF Ultimate LRS 1W.

If I can guess I think I may have messed up idle/min settings of the ESC. Or messed up calibration of drone somehow. I calibrated it just before the trip, and calibration procedure was OK. Maybe I overrided channels related to sticks with my gimball settings?

I have noticed the NO HOME POSITION SET even on v3.4. But when I was flying then, I remember to test the return to home function and It was always working. I think the 3D-15 in lower right corner says I have 3D-fix with 15 satellites. Why no home position then, how to set it?

I have also noticed the ERROR IN WARNING ROUTINE message before. What does this mean, and how to solve this?

Thanks for any help!

No Expert, but those props seem too small. Maybe 9x4 or 10x4 would be better. Also I see a lot of RCIN dropouts- were you going crazy with turning the Tx on and off trying to get control? I have no experience with the UHF system you are using, but can’t believe that is normal. Also why did you change the ESC input to Oneshot? This isn’t a racing machine, so don’t fix what isn’t broken.

If no one else sees an obvious problem, you may want wipe board and redo from scratch on setting it up.

Yes I was trying to turn the radio on/off many times. But I think radio was working OK all the time. I have 5mm clereance to gimbal. 8" is standard size prop for qav400 (
Standard PWM cycle takes 1-4ms. Oneshot is synchronous and uses 1-2ms. Oneshot125 uses 125-250us on the same cycle. Both are analog protocols, but reducing cycle time smooths out noise faster, when analog systems are in use. This should give more smooth, quieter motors.
Is there a reason for why not to use the oneshot protocol instead of the normal?

Z-Vibrations in your later flightwere very high.
Failsafe were configured, but never kicked in - AP never responded to it, reminds me of some of the mess I’ve seen with frsky/taranis config - is that what you use ?

The Motor outputs from his log look very -very odd to me, but I have never used or seen a log with OneShot enabled… Perhaps for my education, can someone who has used OneShot can tell me if this normal type of graph for a OneShot equipped machine?

From a brief look at the log, I could determine the following:

  • The flight controller did not command the increase in altitude. The “throttle out” value was pegged at 0 while the drone was ascending. This means that the flight controller was unable to descend…
  • Vibrations are actually pretty good.
  • The failsafe DID engage and the drone entered RTL mode. However, as mentioned, the flight controller couldn’t descend even though it wanted to.

The flyaway is most likely a result of the instability; if the drone is throwing the motor throttle back and forth wildly in an attempt to stabilize, the overall thrust provided could be greater than the weight of the copter. This leads to a particular type of flyaway; the ATC_THR_MIX_MIN and _MIX_MAN parameters are actually provided as a way to prevent this exact scenario, as it allows you to set the priority of altitude control vs. attitude control at lower power settings. However, of course, you should not have to change these parameters to fly well, the root problem is the instability.

I didn’t have time to take a careful look, but the PIDs seemed reasonable at first glance. My only notes are that they were manually tuned (ie, not Auto-tuned), and the roll rates PIDs seem oddly low (rate roll P is 1/10 the value of rate pitch P, for example).

Interesting observation about that fc did not command increase in altitude.

I had throttle response when launching, but the second the drone was few cm in the air, it took off at full speed. Is the drone aware when it is airborn and not? If so, is there a idle speed setting or min speed setting for motor which kicks inn when the drone is airborn? Where to look for this setting?

Yes, you can change the idle and minimum throttle while flying. These parameters are MOT_SPIN_ARM and MOT_SPIN_MIN. They are expressed as percentages of the full PWM range as configured by MOT_PWM_MIN and MOT_PWM_MAX.

However, I don’t think changing the minimum throttle would have helped in this case. I am quite certain that you experienced a rare type of flyaway caused by the FC committing too much thrust in an attempt to stabilize the drone with unstable PIDs. In the log, you can see the motor throttle banging between ~1200 and ~1600 PWM as it tries to stabilize pitch:

To illustrate, you could make the naive assumption that the PWM was therefore an average of 1400, which could definitely be more than enough to cause the drone to ascend.

And just for fun, here’s a zoomed in graph of all of your motor PWMs that I thought looked rather artistic: