Servers by jDrones

Rugged ArduBoat for Mapping Applications (Continued)


(Scott Macklyn) #61

Hey everyone,

I had my Boat in the water today. All boots up no problems.
But then I encounter some erratic behavior.

When the vessel is armed, in MANUAL mode everything works fine. Left/Right (at a decent speed) and Forward/Reverse (at a great speed). So the next course was to plug in a few way points to see if the AUTO mode would work.
The firs time I did it it went nowhere near the first way point and went straight into some mangroves on the bank. RTL did not work to retrieve it. I had to put it back in MANUAL mode and it responded so I could move it out.

So I then put it in STEERING mode. I can hear a thruster (or both not sure) engage slightly but not enough to move the vessel. Forward/Reverse work fine in this mode but steering is either non existent or very, very slow.

Then after some time I tried 2 Way points in AUTO and it seemed to work fine. Then RTL and it came home, very slow and sort of slowly wobbled to get back.

One of the main things that happens is I get EXF errors for the Compass. Also Compass Variance comes and goes during a setup. I disabled the Pixhawk Compass and use the GPS compass. (I may just need to do a re-calibration?)

I have attached the log file where it went crazy (you can clearly see the compass is not aligned with the vehicle direction)

For some reason the Log for when it went between 2 waypoints and then RTL isn’t stored locally. I wll have to see if its on the pixhawk.

If anyone has any ideas on this, I would be very grateful for your input.
https://fredmacassociates-my.sharepoint.com/personal/scott_macklyn_fredmac_com_au/_layouts/15/guestaccess.aspx?folderid=0670a4fcbfd994dcdb9e35b64f7ddc097&authkey=AbMbK6bnYF77ha96W_3On94&expiration=2017-09-29T14%3A00%3A00.000Z


(Scott Macklyn) #62

Hi Guys,

In relation to my last post, I did the setup again and had no errors. It did a survey mission just fine. RTL worked fine. I did a mission 3 times in a row and had no errors. So unsure of what the main problem was. Only thing I did was enable the Pixhawk Compass again.

Manual, Steering, Auto and Hold modes all work, as well at the RTL.

@Kevin_K I have a question regarding power. I have used 2 x Multistar 4S 10,000mAh batteries thus far. What is the expected runtime I could expect out of these? I am looking at getting 2 x 4S 16,000mAh (32,000mAh) or 2 x 4S 20,000mAh (40,000mAh) batteries for sustained peroids of underwater sonar survey.
But once again, I must thank you for your help and for contributing all of your work to this forum. Without it I would not have made the jump to build my own. Down the track I want to redesign my own hull to contain everything inside the hull and cut down on excess weight.

Cheers, Scott.


(Kevin Klemens) #63

@Penjack7 Ok great! I was just about to circle back and offer some troubleshooting advice. Glad it all works now. I would love to see a picture or a video of your vehicle when you get the chance.

Regarding power, with the 2x 4S 10,000mAh batteries in parallel, you will probably be looking at around 2 hours at full power and powering a sonar. I also trialed the 2x 4S 20,000mAh batteries, but I’m not sure how long they ran for. I lent it to BlueRobotics in that configuration and I think they got 3-4 hours. I have since switched out my batteries to 2x 18,000mAh Li-Ion batteries from BlueRobotics because I really hate taking care of Li-Po’s and these are much more stable in a marine environment. http://bluerobotics.com/store/rov/bluerov2/battery-li-4s-18ah-r1/

I’ll be looking forward to your next project, I’m also trimming down my weight and moving towards something smaller that won’t take the entire back end of my truck: http://discuss.bluerobotics.com/t/3d-printed-usv-hull-files-available-on-hackaday/1217


(Scott Macklyn) #64

Awesome thanks Kevin. I will only be powering the thrusters and Pixhawk. The sonar and GPS system have their own power sources (internal batteries).

When you say full power, what speed were you travelling at to capture data? When I run an auto mission, the speed ranges at 1.5m/s. I do set the mission to 5m/s and tried 1m/s but doesn’t affect it. When I did the 1m/s it actually came up with an error for the command and ignored it, and continued as normal. When I have been running at this normal speed (1.5m/s), the HUD is showing about 8-10amps that the vehicle is using. Full power would be up around 24 amps? I had a play again this morning and noticed that the battires went down 5-6% for about 20-30 minutes use.

By using the Li-Ion Batteries, is run time affected? Is it a similar run time or shorter/longer?
Thanks again,
Scott


(Kevin Klemens) #65

I think I was traveling between 1.5-2.0m/s. If you are using Mission Planner, there is a screen to adjust the cruise speed settings. 24A sounds reasonable. each of the T200s draws around 12-14A when full out.

I haven’t done a full endurance run with my Li-ion batteries yet, but they seem similar in performance to the 2x 20,000mAh packs.


(Scott Macklyn) #66

@Kevin_K
I have tried to adjust the speed but It never changed. It seems to stay at the constatn 1.5m/s, thats not bad but would be good to try and do a fast run. Not sure why it won’t set. I will go back try the tuning procedure again.

Also, not sure if you or anyone else here can help with the steering. Skid Steer Out works like a charm on a right hand turn, but the left hand turn goes wider for some reason. (i will try upload a screen shot when I get home tonight). Not sure why it does that and can’t see a setting that would affect it, since the right hand works fine. So when turning right it turns on itself real nice, but the left wants to go out further and do a wider turn then back onto the waypoint line. Any ideas? As above I may try the tuning process again.

Thanks,
Scott


(David Boulanger) #67

Penjack7 are you using counter rotating thrusters. Sounds like it could be prop steer if not. Actually now that I think a bit more it should be all the same in each direction. I’ve had this problem before and the wind was causing it.


(Scott Macklyn) #68

Hi David,
No just the standard clockwise props that were preinstalled in the T100s. I have a set of counter-clockwise thrusters also that came with it. Not sure if I should have 1 of each or not. Yeah wasnt any wind about, very weird. Thanks for your reply,
Scott


(Kevin Klemens) #69

A good practice for marine vehicles is to use counter rotating propellers. I have mine set-up as “out at the top” so the side force from the propellers helps me in turns.


(Scott Macklyn) #70

Ah right, so one prop on each should help then @Kevin_K? I will try that today. Any side will do as long as they are one of each?


(Kevin Klemens) #71

If you are looking from the stern to the bow, I’d recommend having the starboard (right) propeller turn clockwise when going forwards and the port (left) propeller turning counter-clockwise. I know it’s a bit of a pain changing out propellers, but this should get you going straight as an arrow.


(Scott Macklyn) #72

@Kevin_K I switched out the left propeller with the counter-clockwise. I then reversed the RC1 channel to correct for this change. In MANUAL it went forward, left and right. (Left and right both turn roughly same distance. Not sharp but gradually). When switched to AUTO it goes to do the mission in reverse. So i switched RC1 back to normal and switched RC3. This worked, both Manual and AUTO. The AUTO was very wobbly and I adjusted the settings as per the ArduRover page. No change though.

It seems to not be working the same as when I had it first going from just all standard settings when I first put it in the water. (both with normal clockwise props). One thing to note is when going in a straight line, it moves to the right gradually. Not sure how to fix that. Is it controlling the PWM outputs?

Speed is still an issue. If I have it full throttle in MANUAL mode I can see the amps shoot up to around 25-30A but the speed stays around 1.5m/s. I cannot get it to go faster than this. Doing a mission it sits on 1.2-1.5 (depending on wind) and uses 12.0A total.


(Kevin Klemens) #73

@Penjack7 You have to keep RC1 and RC3 “Normal”. Manually switch two of the brushless motor wires. Rover up to 3.2.0 is really picky on its settings and for skid steering to work properly, everything pretty much has to be set up standard. I learned that lesson because I had the same problem you are currently having in AUTO.

You other option is to load up ArduSub 3.5 and use the 3-Thruster frame…without the vertical thruster.

Hmm, I’m not sure why it is moving to the right gradually. That might be a build issue if one of the thrusters is slightly tweaked to the right.

You may also be maxing out your hull form for speed. I haven’t played with cruise speed setting that much.

As a last thought, you can always play with the SITL in Mission planner to play with the settings and see what happens when you adjust the parameters.


(Scott Macklyn) #74

Ah right, thanks for the heads up. Will change the RC back to normal and switch two wires (on the prop I changed I presume?).

I will double check the alignment, but when I measured it all up after the install I had 2mm error.

Will see if I can get the SITL in Mission Planner working. My PC won’t download the SITL drivers with getting a repsone from AntiVirus Software. I will keep playing.

Once again, thanks for guidance.


(Kevin Klemens) #75

Yes, that is correct, change the wire for the propeller you changed.


(Scott Macklyn) #76

Thought I would give an update on my vessel.
After scratching my head and not getting anything working during testing (except for manual mode) I had to take it onsite for work to do some hydrographic surveying. Well low and behold it worked seamlessly! Auto mode worked fine. As well as Manual in the tight spots. Speed is still only at 1.2-1.5m/s but seems good enough to get a sounding shot and a GPS RTK position together.

The main thing that has thrown me out, is on my Futaba 14SG Controller, the throttle is reversed. Once I just got it in my head that it was the correct way, everything worked. I just over thought the whole project.

Did possibly 3-5km on just 2x10,000mah 4S Lipos (Multistar). And the survey data is perfect.

I can not thank everyone enough for their input into this thread. Most notably @Kevin_K, without your help I would not have got this going.

I will eventually get some photos up of the build. But next on the list is a better hull design and reduce the size for easier transporting and storage.

Thanks again guys,
Scott


(gmorph) #77

Great news that its all working so well. Excellent community support.

Thanks, Grant.