RTT too High For Timesync with SITL (MAVROS)

I have been using Ardupilot SITL with Mavros for a few months now. However, after doing some package upgrades I am now getting the error:

[ WARN] [1549505082.337265272]: TM : RTT too high for timesync: 20.48 ms.

When launching Mavros to connect to Ardupilot SITL.

Does anyone know how to solve this issue?

Thanks!

Here is my window:


Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://konglab-OptiPlex-9020:44249/

SUMMARY

CLEAR PARAMETERS

  • /mavros/

PARAMETERS

  • /mavros/cmd/use_comp_id_system_control: False
  • /mavros/conn/heartbeat_mav_type: ONBOARD_CONTROLLER
  • /mavros/conn/heartbeat_rate: 1.0
  • /mavros/conn/system_time_rate: 1.0
  • /mavros/conn/timeout: 10.0
  • /mavros/conn/timesync_rate: 10.0
  • /mavros/distance_sensor/rangefinder_pub/field_of_view: 0.0
  • /mavros/distance_sensor/rangefinder_pub/frame_id: lidar
  • /mavros/distance_sensor/rangefinder_pub/id: 0
  • /mavros/distance_sensor/rangefinder_pub/send_tf: False
  • /mavros/distance_sensor/rangefinder_pub/sensor_position/x: 0.0
  • /mavros/distance_sensor/rangefinder_pub/sensor_position/y: 0.0
  • /mavros/distance_sensor/rangefinder_pub/sensor_position/z: -0.1
  • /mavros/distance_sensor/rangefinder_sub/id: 1
  • /mavros/distance_sensor/rangefinder_sub/orientation: PITCH_270
  • /mavros/distance_sensor/rangefinder_sub/subscriber: True
  • /mavros/fake_gps/eph: 2.0
  • /mavros/fake_gps/epv: 2.0
  • /mavros/fake_gps/fix_type: 3
  • /mavros/fake_gps/geo_origin/alt: 408.0
  • /mavros/fake_gps/geo_origin/lat: 47.3667
  • /mavros/fake_gps/geo_origin/lon: 8.55
  • /mavros/fake_gps/gps_rate: 5.0
  • /mavros/fake_gps/mocap_transform: True
  • /mavros/fake_gps/satellites_visible: 5
  • /mavros/fake_gps/tf/child_frame_id: fix
  • /mavros/fake_gps/tf/frame_id: map
  • /mavros/fake_gps/tf/listen: False
  • /mavros/fake_gps/tf/rate_limit: 10.0
  • /mavros/fake_gps/tf/send: False
  • /mavros/fake_gps/use_mocap: True
  • /mavros/fake_gps/use_vision: False
  • /mavros/fcu_protocol: v2.0
  • /mavros/fcu_url: udp://127.0.0.1:1…
  • /mavros/gcs_url: udp://@localhost
  • /mavros/global_position/child_frame_id: base_link
  • /mavros/global_position/frame_id: map
  • /mavros/global_position/gps_uere: 1.0
  • /mavros/global_position/rot_covariance: 99999.0
  • /mavros/global_position/tf/child_frame_id: base_link
  • /mavros/global_position/tf/frame_id: map
  • /mavros/global_position/tf/global_frame_id: earth
  • /mavros/global_position/tf/send: False
  • /mavros/global_position/use_relative_alt: True
  • /mavros/image/frame_id: px4flow
  • /mavros/imu/angular_velocity_stdev: 0.000349065850399
  • /mavros/imu/frame_id: base_link
  • /mavros/imu/linear_acceleration_stdev: 0.0003
  • /mavros/imu/magnetic_stdev: 0.0
  • /mavros/imu/orientation_stdev: 1.0
  • /mavros/local_position/frame_id: map
  • /mavros/local_position/tf/child_frame_id: base_link
  • /mavros/local_position/tf/frame_id: map
  • /mavros/local_position/tf/send: False
  • /mavros/local_position/tf/send_fcu: False
  • /mavros/mission/pull_after_gcs: True
  • /mavros/mocap/use_pose: True
  • /mavros/mocap/use_tf: False
  • /mavros/odometry/estimator_type: 3
  • /mavros/odometry/frame_tf/desired_frame: ned
  • /mavros/plugin_blacklist: ['actuator_contro…
  • /mavros/plugin_whitelist: []
  • /mavros/px4flow/frame_id: px4flow
  • /mavros/px4flow/ranger_fov: 0.118682389136
  • /mavros/px4flow/ranger_max_range: 5.0
  • /mavros/px4flow/ranger_min_range: 0.3
  • /mavros/safety_area/p1/x: 1.0
  • /mavros/safety_area/p1/y: 1.0
  • /mavros/safety_area/p1/z: 1.0
  • /mavros/safety_area/p2/x: -1.0
  • /mavros/safety_area/p2/y: -1.0
  • /mavros/safety_area/p2/z: -1.0
  • /mavros/setpoint_accel/send_force: False
  • /mavros/setpoint_attitude/reverse_thrust: False
  • /mavros/setpoint_attitude/tf/child_frame_id: target_attitude
  • /mavros/setpoint_attitude/tf/frame_id: map
  • /mavros/setpoint_attitude/tf/listen: False
  • /mavros/setpoint_attitude/tf/rate_limit: 50.0
  • /mavros/setpoint_attitude/use_quaternion: False
  • /mavros/setpoint_position/mav_frame: LOCAL_NED
  • /mavros/setpoint_position/tf/child_frame_id: target_position
  • /mavros/setpoint_position/tf/frame_id: map
  • /mavros/setpoint_position/tf/listen: False
  • /mavros/setpoint_position/tf/rate_limit: 50.0
  • /mavros/setpoint_velocity/mav_frame: LOCAL_NED
  • /mavros/startup_px4_usb_quirk: False
  • /mavros/sys/disable_diag: False
  • /mavros/sys/min_voltage: 10.0
  • /mavros/target_component_id: 1
  • /mavros/target_system_id: 1
  • /mavros/tdr_radio/low_rssi: 40
  • /mavros/time/time_ref_source: fcu
  • /mavros/time/timesync_avg_alpha: 0.6
  • /mavros/time/timesync_mode: MAVLINK
  • /mavros/vibration/frame_id: base_link
  • /mavros/vision_pose/tf/child_frame_id: vision_estimate
  • /mavros/vision_pose/tf/frame_id: map
  • /mavros/vision_pose/tf/listen: False
  • /mavros/vision_pose/tf/rate_limit: 10.0
  • /mavros/vision_speed/listen_twist: True
  • /mavros/vision_speed/twist_cov: True
  • /rosdistro: kinetic
  • /rosversion: 1.12.14

NODES
/
mavros (mavros/mavros_node)

auto-starting new master
process[master]: started with pid [6908]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to b86732d0-2a7c-11e9-9d92-7cdd90a327fc
process[rosout-1]: started with pid [6921]
started core service [/rosout]
process[mavros-2]: started with pid [6939]
[ INFO] [1549505077.666397844]: FCU URL: udp://127.0.0.1:14551@14555
[ INFO] [1549505077.667565447]: udp0: Bind address: 127.0.0.1:14551
[ INFO] [1549505077.667610600]: udp0: Remote address: 0.0.56.219:14550
[ INFO] [1549505077.667671158]: GCS URL: udp://@localhost
[ INFO] [1549505077.667717571]: udp1: Bind address: 0.0.0.0:14555
[ INFO] [1549505077.667765592]: udp1: Remote address: 127.0.0.1:14550
[ INFO] [1549505077.675645198]: Plugin 3dr_radio loaded
[ INFO] [1549505077.676991634]: Plugin 3dr_radio initialized
[ INFO] [1549505077.677015752]: Plugin actuator_control blacklisted
[ INFO] [1549505077.679346939]: Plugin adsb loaded
[ INFO] [1549505077.682434429]: Plugin adsb initialized
[ INFO] [1549505077.682454391]: Plugin altitude blacklisted
[ INFO] [1549505077.682516112]: Plugin cam_imu_sync loaded
[ INFO] [1549505077.683007230]: Plugin cam_imu_sync initialized
[ INFO] [1549505077.683084102]: Plugin command loaded
[ INFO] [1549505077.687255672]: Plugin command initialized
[ INFO] [1549505077.687368037]: Plugin companion_process_status loaded
[ INFO] [1549505077.689443950]: Plugin companion_process_status initialized
[ INFO] [1549505077.689462296]: Plugin debug_value blacklisted
[ INFO] [1549505077.689528127]: Plugin distance_sensor loaded
[ INFO] [1549505077.698518660]: Plugin distance_sensor initialized
[ INFO] [1549505077.698606570]: Plugin fake_gps loaded
[ INFO] [1549505077.710847165]: Plugin fake_gps initialized
[ INFO] [1549505077.710871380]: Plugin ftp blacklisted
[ INFO] [1549505077.710972235]: Plugin global_position loaded
[ INFO] [1549505077.723164551]: Plugin global_position initialized
[ INFO] [1549505077.723236034]: Plugin gps_rtk loaded
[ INFO] [1549505077.725092907]: Plugin gps_rtk initialized
[ INFO] [1549505077.725109753]: Plugin hil blacklisted
[ INFO] [1549505077.725182750]: Plugin home_position loaded
[ INFO] [1549505077.728335069]: Plugin home_position initialized
[ INFO] [1549505077.728415272]: Plugin imu loaded
[ INFO] [1549505077.734114658]: Plugin imu initialized
[ INFO] [1549505077.734191423]: Plugin local_position loaded
[ INFO] [1549505077.735740720]: udp0: Remote address: 127.0.0.1:56827
[ INFO] [1549505077.739406718]: Plugin local_position initialized
[ INFO] [1549505077.739518192]: Plugin log_transfer loaded
[ INFO] [1549505077.741598593]: Plugin log_transfer initialized
[ INFO] [1549505077.741713274]: Plugin manual_control loaded
[ INFO] [1549505077.744185024]: Plugin manual_control initialized
[ INFO] [1549505077.744293581]: Plugin mocap_pose_estimate loaded
[ INFO] [1549505077.747929252]: Plugin mocap_pose_estimate initialized
[ INFO] [1549505077.748048404]: Plugin obstacle_distance loaded
[ INFO] [1549505077.753954115]: Plugin obstacle_distance initialized
[ INFO] [1549505077.754041213]: Plugin odom loaded
[ INFO] [1549505077.758402979]: Plugin odom initialized
[ INFO] [1549505077.758509702]: Plugin param loaded
[ INFO] [1549505077.760719241]: Plugin param initialized
[ INFO] [1549505077.760736279]: Plugin px4flow blacklisted
[ INFO] [1549505077.760818581]: Plugin rangefinder loaded
[ INFO] [1549505077.761493590]: Plugin rangefinder initialized
[ INFO] [1549505077.761582192]: Plugin rc_io loaded
[ INFO] [1549505077.765377084]: Plugin rc_io initialized
[ INFO] [1549505077.765400159]: Plugin safety_area blacklisted
[ INFO] [1549505077.765491090]: Plugin setpoint_accel loaded
[ INFO] [1549505077.768595832]: Plugin setpoint_accel initialized
[ INFO] [1549505077.768700265]: Plugin setpoint_attitude loaded
[ INFO] [1549505077.777369410]: Plugin setpoint_attitude initialized
[ INFO] [1549505077.777453513]: Plugin setpoint_position loaded
[ INFO] [1549505077.789201560]: Plugin setpoint_position initialized
[ INFO] [1549505077.789297447]: Plugin setpoint_raw loaded
[ INFO] [1549505077.796778107]: Plugin setpoint_raw initialized
[ INFO] [1549505077.796865543]: Plugin setpoint_velocity loaded
[ INFO] [1549505077.801520452]: Plugin setpoint_velocity initialized
[ INFO] [1549505077.801613358]: Plugin sys_status loaded
[ INFO] [1549505077.810700856]: Plugin sys_status initialized
[ INFO] [1549505077.810800193]: Plugin sys_time loaded
[ INFO] [1549505077.815506108]: TM: Timesync mode: MAVLINK
[ INFO] [1549505077.816408319]: Plugin sys_time initialized
[ INFO] [1549505077.816481089]: Plugin trajectory loaded
[ INFO] [1549505077.820753011]: Plugin trajectory initialized
[ INFO] [1549505077.820876877]: Plugin vfr_hud loaded
[ INFO] [1549505077.821410407]: Plugin vfr_hud initialized
[ INFO] [1549505077.821436883]: Plugin vibration blacklisted
[ INFO] [1549505077.821523016]: Plugin vision_pose_estimate loaded
[ INFO] [1549505077.828062948]: Plugin vision_pose_estimate initialized
[ INFO] [1549505077.828097230]: Plugin vision_speed_estimate blacklisted
[ INFO] [1549505077.828214076]: Plugin waypoint loaded
[ INFO] [1549505077.832318992]: Plugin waypoint initialized
[ INFO] [1549505077.832435592]: Plugin wind_estimation loaded
[ INFO] [1549505077.833012311]: Plugin wind_estimation initialized
[ INFO] [1549505077.833056492]: Built-in SIMD instructions: SSE, SSE2
[ INFO] [1549505077.833079933]: Built-in MAVLink package version: 2019.1.12
[ INFO] [1549505077.833112677]: Known MAVLink dialects: common ardupilotmega ASLUAV autoquad icarous matrixpilot paparazzi slugs standard uAvionix ualberta
[ INFO] [1549505077.833140813]: MAVROS started. MY ID 1.240, TARGET ID 1.1
[ INFO] [1549505078.011358135]: RC_CHANNELS message detected!
[ INFO] [1549505078.011637949]: IMU: Raw IMU message used.
[ WARN] [1549505078.011682445]: IMU: linear acceleration on RAW_IMU known on APM only.
[ WARN] [1549505078.011707902]: IMU: ~imu/data_raw stores unscaled raw acceleration report.
[ INFO] [1549505078.380729011]: CON: Got HEARTBEAT, connected. FCU: ArduPilot - Plane/Copter/Rover/Sub/Tracker
[ WARN] [1549505078.448197314]: TM : RTT too high for timesync: 31.22 ms.
[ INFO] [1549505078.522085311]: RC_CHANNELS message detected!
[ WARN] [1549505079.049704310]: TM : RTT too high for timesync: 32.30 ms.
[ INFO] [1549505079.383484646]: VER: 1.1: Capabilities 0x0000000000003bcf
[ INFO] [1549505079.383519820]: VER: 1.1: Flight software: 03070000 ( c3e11fd)
[ INFO] [1549505079.383543305]: VER: 1.1: Middleware software: 00000000 ( )
[ INFO] [1549505079.383567764]: VER: 1.1: OS software: 00000000 ( )
[ INFO] [1549505079.383589801]: VER: 1.1: Board hardware: 00000000
[ INFO] [1549505079.383609724]: VER: 1.1: VID/PID: 0000:0000
[ INFO] [1549505079.383627954]: VER: 1.1: UID: 0000000000000000
[ WARN] [1549505079.383800677]: CMD: Unexpected command 520, result 0
[ WARN] [1549505079.937219002]: TM : RTT too high for timesync: 19.89 ms.
[ WARN] [1549505080.529221791]: TM : RTT too high for timesync: 12.31 ms.
[ WARN] [1549505081.131599148]: TM : RTT too high for timesync: 14.20 ms.
[ WARN] [1549505081.744015273]: TM : RTT too high for timesync: 26.93 ms.
[ WARN] [1549505082.337265272]: TM : RTT too high for timesync: 20.48 ms.
[ WARN] [1549505082.931483127]: TM : RTT too high for timesync: 14.35 ms.
[ WARN] [1549505083.536013694]: TM : RTT too high for timesync: 19.14 ms.
[ WARN] [1549505084.149474057]: TM : RTT too high for timesync: 33.01 ms.
[ WARN] [1549505086.433129187]: TM : RTT too high for timesync: 15.73 ms.
[ WARN] [1549505087.837314281]: TM : RTT too high for timesync: 19.91 ms.
[ INFO] [1549505088.381699204]: HP: requesting home position
[ INFO] [1549505088.413556188]: FCU: ArduCopter V3.7.0-dev (c3e11fd3)
[ INFO] [1549505088.413786140]: FCU: a43d79cd4f2f4568bda5b7d7a947013d
[ INFO] [1549505088.414040610]: FCU: Frame: QUAD
[ WARN] [1549505089.382562649]: PR: request list timeout, retries left 2
[ WARN] [1549505090.383130272]: PR: request list timeout, retries left 1
[ WARN] [1549505091.383480504]: PR: request list timeout, retries left 0
[ WARN] [1549505093.383244351]: CMD: Unexpected command 410, result 0
[ WARN] [1549505093.410068340]: TM : RTT too high for timesync: 4993.13 ms.
[ WARN] [1549505093.411560021]: TM : RTT too high for timesync: 4394.15 ms.
[ INFO] [1549505093.412457801]: FCU: ArduCopter V3.7.0-dev (c3e11fd3)
[ INFO] [1549505093.412754958]: FCU: a43d79cd4f2f4568bda5b7d7a947013d
[ INFO] [1549505093.413066715]: FCU: Frame: QUAD
[ WARN] [1549505093.413701760]: TM : RTT too high for timesync: 3796.39 ms.
[ WARN] [1549505093.414920941]: TM : RTT too high for timesync: 3197.44 ms.
[ INFO] [1549505093.415401516]: FCU: ArduCopter V3.7.0-dev (c3e11fd3)
[ INFO] [1549505093.415755562]: FCU: a43d79cd4f2f4568bda5b7d7a947013d
[ INFO] [1549505093.416017706]: FCU: Frame: QUAD
[ WARN] [1549505093.417061534]: TM : RTT too high for timesync: 2600.62 ms.
[ INFO] [1549505093.418357475]: FCU: ArduCopter V3.7.0-dev (c3e11fd3)
[ INFO] [1549505093.418633173]: FCU: a43d79cd4f2f4568bda5b7d7a947013d
[ INFO] [1549505093.418869953]: FCU: Frame: QUAD
[ WARN] [1549505093.419083989]: TM : RTT too high for timesync: 2002.31 ms.
[ WARN] [1549505093.420329338]: TM : RTT too high for timesync: 1403.86 ms.
[ WARN] [1549505093.421531206]: TM : RTT too high for timesync: 804.51 ms.
[ WARN] [1549505093.422728453]: TM : RTT too high for timesync: 206.12 ms.
[ INFO] [1549505093.423175786]: WP: mission received
[ WARN] [1549505093.879323724]: TM : RTT too high for timesync: 62.84 ms.
[ INFO] [1549505094.021829161]: PR: parameters list received
[ WARN] [1549505094.446008715]: TM : RTT too high for timesync: 28.53 ms.
[ WARN] [1549505095.039028950]: TM : RTT too high for timesync: 21.73 ms.
[ WARN] [1549505095.643658069]: TM : RTT too high for timesync: 26.24 ms.
[ WARN] [1549505096.243200155]: TM : RTT too high for timesync: 25.82 ms.
[ WARN] [1549505096.842836361]: TM : RTT too high for timesync: 26.16 ms.
[ WARN] [1549505097.445634188]: TM : RTT too high for timesync: 28.65 ms.
[ WARN] [1549505098.043852141]: TM : RTT too high for timesync: 27.15 ms.
[ WARN] [1549505098.643177538]: TM : RTT too high for timesync: 26.24 ms.
[ WARN] [1549505099.244740546]: TM : RTT too high for timesync: 28.04 ms.
[ WARN] [1549505099.841209595]: TM : RTT too high for timesync: 24.29 ms.
[ WARN] [1549505100.444034334]: TM : RTT too high for timesync: 26.99 ms.
[ WARN] [1549505101.045867401]: TM : RTT too high for timesync: 28.55 ms.
[ WARN] [1549505101.641854596]: TM : RTT too high for timesync: 25.06 ms.
[ WARN] [1549505102.240245827]: TM : RTT too high for timesync: 23.46 ms.
[ WARN] [1549505102.845131374]: TM : RTT too high for timesync: 28.44 ms.
[ WARN] [1549505103.446277971]: TM : RTT too high for timesync: 29.56 ms.
[ WARN] [1549505104.042857795]: TM : RTT too high for timesync: 26.38 ms.
[ WARN] [1549505104.642914148]: TM : RTT too high for timesync: 25.53 ms.
[ WARN] [1549505105.246173291]: TM : RTT too high for timesync: 29.19 ms.
[ WARN] [1549505105.843169217]: TM : RTT too high for timesync: 25.74 ms.
[ WARN] [1549505106.445547629]: TM : RTT too high for timesync: 28.25 ms.
[ WARN] [1549505107.046932884]: TM : RTT too high for timesync: 29.59 ms.
[ WARN] [1549505107.639747948]: TM : RTT too high for timesync: 22.89 ms.

Change timesync_rate to 0.0

Will that negatively affect other parts of the system?

Did setting timesync to 0 solve your problem?
I am getting the same warning and I have a feeling it is affecting offboard control (not sure). Let me know if you solved it.
Thank you

It did remove the warning. It hasn’t seemed to negatively affect anything for the time being.

Please advise. How do I set the timesync_rate? (Sorry learning ROS)

I changed it in the apm_config.yaml in the mavros folder, search for “timesync”.

I stumbled on this problem too in my system.
In case anyone is still wondering, mavros is actually setting a parameter in that yaml file. So, if you want to override it without editing the yaml file, you can use the <param> tag in your launch file.

For example:
<param name="/mavros/conn/timesync_rate" value="0.0"/>

Doesn’t that fully disable the time synchronization between the two systems? What are the side-effects?

I tried with:

<param name="/mavros/conn/timesync_rate" value="0.1"/>

at the end of the launch file and it got rid of the RTT too High For Timesync messages. A value of 1.0 also got me three of these messages at the start of the connection but then they stopped. Perhaps you could experiment with your system and find a value that works before hammering it with a value of 0.

Correction: the messages do not actually stop, if you let SITL run for long, you still get them but their frequency is greatly reduced.