Servers by jDrones

RTSP Streaming Video not working on 4.0.6

Hi folks, hope your all staying health and able to get out and fly.
I have a problem streaming video from any of my sky viper v2450 GPS drones to QGC on my Android tablet. I had the video working fine streaming RTSP but somehow QGC got auto updated along with half dozen other apps from the app store. After resetting all the global setting that were deleted I noticed that the RTSP info was gone as well. I added the RTSP info like I had setup before (thanks to all the info from several of you) and went to fly then discovered that the video window was black with msg “Video Disabled” . After a couple of hours searching I found the screen to “Enable Video” over in the Telemetry window setup screens, (why there instead of the video window itself). After enabling streaming there’s still a blank video window but it just says “Waiting for Video” . There’s video showing up fine in the SkyViper App and the Sonic board WEB interface but nothing in QGC. I double checked the RTSP setup info I entered and it looks correct ( RTSP://192.168.99.1:554/media/stream2 ).
I’ve tried restart QGC and the drones several times but nothing is showing in the video window. I’ve gone over the DOC’s a couple of times (the Video Streaming docs need some serious spell check and the item about More Video info on GitHub is a bad link 404) and see there’s several new items for different streams, I tried a couple of them but still no video using RTSP.
Have any of you tried streaming from SkyViper GPS to the QGC 4.0.6 and have video working? I’ve been over on GitHub and see there’s several issues with RTSP and UDP to Android QGC but nothing specific about SkyViper GPS.
I’m having to fly with the SkyViper App video on a small cell phone that I can’t see too well and sure would like to have QGC w video on my Lenovo 8" tablet (Android 7.0), was starting to get setup to fly multiple vipers but can’t do it with SkyViper app.
dp

Solved:
In QGC 4.0.6 for Android, when entering RTSP Target you cannot use Capital letters. Seems it was allowed in the 3.5.x version but not in current version.

Thanks for reporting back on the solution. I’ll take a look at possibly putting back capital letter support.

1 Like

QGC Issue: https://github.com/mavlink/qgroundcontrol/issues/8780

Servers by jDrones