RTL with RTK set up

I’m using here+ RTK setup for my octa-copter along with GPS blending using two Here3 GPS modules as the rover in the setup. In RTL mode the octa landed near the base of the RTK and not at the place from where it was launched.
Any help would be appreciated.

Update to ArduCopter 4.2.1-rc1 and make sure you get a good gps signal before taking off

1 Like

Hello @Mayuri

Be sure that you are flying with your GPS status showing RTK Float or RTK Fix, and be sure that you are using a nice accuracy for the survey-in procedure of your RTK base.

1 Like

I had a similar experience when we first started using RTK; my expectation was the RTL position would be more accurate than it was. Reducing the EKF GPS noise measurement parameters, like EK3_POSNE_M_NSE, improved the RTL accuracy. I think that reducing the parameter causes the EKF to trust the GPS more which is warranted when using RTK.

1 Like