Servers by jDrones

RTL problem param list

(Ehsan Jamshidi) #1

Hello All,
I flew yesterday with my copter and I came up with a very interesting question for my self!!
when my copter was about 0.5m above the ground ,I noticed the battery is low , so I wanted to land but what happened was , the mode changed to RTL , since it was selected for the fail safe mode to do so.
but What it got my attention was that the copter was going higher and higher although I put the RTL_ALT to 50 cm which is 0.5m so it needed not to higher than this ALT. am I right ?

I checked in the param list And I saw the RTL-ALT can be choosen from 0 to 8000 cm . and I had chosen this to be 50 cm before.
now I saw in the webpage of ardupilot the range is showing a number between 200 to 8000cm.
why these two number in param list and ardupilot page is different ? which one is correct ?

RTL_ALT: RTL Altitude

Range Increment Units
200 - 8000 1 centimeters
(Amilcar Lucas) #2

That is the altitude that the copter uses when returning to home (RTL) setting it to 50 cm is probably a bad idea. the copter will hit any obstacle that is higher than 50 cm on the way home (assuming that when RTL got triggered you where flying bellow 50 cm) Otherwise it would keep his height , no matter how low it was.
Please keep that parameter as high as the highest obstacle around you.

(Ehsan Jamshidi) #3

Hello,
@amilcarlucas Thanks for your kind reply.
ply check for RTL_ALT =… in the param list from mission planner , here is written we can choose between 0 to 8000cm.
but in the webpage of ardupilot we have

RTL_ALT: RTL Altitude

Range Increment Units
200 - 8000 1 centimeters

I would say we need to follow the ardupilot page since in the mission planner when we check for this param the range is wrong!!! since its not working when you choose the option less than 200cm .
Best Regards,

(Richard) #4

RTL_ALT_MIN is set to 200 cm in the config.h file which is why Copter will never go below 2m when RTL is triggered. RTL_ALT_MIN is not shown in mission planner. Is the only way to change it to modify config.h and recompile or is there another way to override it?. I know that flying below 2m is not wise but I understand that this test is being performed outside with a safety net that is only about 2m in height.

(Ehsan Jamshidi) #5

Yes,this Test is being drone Insider of the net with less than 2m in height. Is theere any way to configure this file and Upload the new Firmware which is the min of height is set to 50cm , for this FC ?
MY flight Controller:

(Amilcar Lucas) #6

Yes, you need to change the RTL_ALT_MIN constant and recompile the code, uploade it to the HK32, and have fun.