RTL does not return to launch nor lands, but kind of loiters

Hi everyone,

After changing my RC to ER9X software (followed by radio calibration, ESC calibration, compass calibration, accelerometer calibration), changing loiter flight mode to PosHold and defining RTL for the ch8 switch, plus modifying Thr-DZ=50 and Thr-Mid=620, my quadcopter does not return to launch nor lands when RTL mode engages (via ch8 switch as well as via battery voltage failsafe): see flight log dropbox.com/s/b8ynng9qutlea … .bin?dl=0; first RTL = switch; second RTL = battery FS.

Switching to RTL was confirmed by APM Planner (and the log). Home position: 7 sats at arming, 9 resp 10 at RTL, HDOP at arming <2.0, GPS position confirmed to be correct in APM Planner map.

Behaviour at RTL: copter climbs very slowly, no horizontal movement, no reaction to pitch and roll sticks. Intended RTL=“climb to 30m, fly to home, land”. Regained control when switching back to PosHold or AltHold. Behaviour confirmed in two later flights. In the past, RTL worked perfectly for same copter, same APM Copter version. Vibration, compass error etc seems to be OK.

I have no idea what caused this change in behaviour, nor do I know where to start looking for correcting it. Any help appreciated!

Pixhawk with latest APM Copter 3.2
Hobbyking 9X with ER9X firmware

From the logs it looks like it did go into RTL. The problem in each case is that you overrode this option.
When you set switch 8 to do RTL it must stay in that position otherwise it will return to what ever mode was last used.
When battery failsafe happens the copter went into RTL. You then selected ALT Hold and later Position hold. This overrides RTL and stops it from continuing in that mode.


Thanks, Mike.

Let me clarify: in both cases (switch & battery failsafe), I switched back to Poshold because my copter did not do anything in RTL mode.

When RTL worked in the past, my copter immediately and rapidly climbed to 30m, flew to the home position, hovered 5" above home and landed. The last three flights, the copter hardly climbed and did not fly home; it just stayed hovering. To get control back, I switched to Poshold after about 40".


From the logs I did see the copter start to climb but then it was switched out after about 15 seconds or so based on the logs.

So you say that it enters RTL and then just sits there and does not climb or return to home.

I would do anther simple test and set RTL and let it sit there for a few minutes and post that log.


Thanks for the tip, Mike.

I Just tried out RTL again, but now for several minutes. Only change to parameters compared to last time: RTL_ALT=1500 instead of 3000 during previous flight.

Observed behaviour the same: copter very slowly and steadily climbs while keeping horizontal position. At close to 40m above ground (well above the 15m dictated by RTL_ALT!), I switched to AltHold and PosHold to bring back the copter since I was exceeding the legal limit of 30m.
Datalog file: dropbox.com/s/x12sp3a35entm … 4.bin?dl=0
tlog file: dropbox.com/s/67wojlj5zhmwt … .tlog?dl=0

As indicated in my first post, RTL worked in the past for the same copter. See datalog dropbox.com/s/hdbel2a797rqv … 4.bin?dl=0 where RTL was engaged at the end of the flight (battery failsafe); copter rapidly climbed to 15m, came home and landed as it should.

Any help appreciated!


I think I found it. WPNAV_SPEED = 0 and WPNAV_SPEED_UP = 0 and WPNAV_SPEED_DN =0,

I think if you tried an auto mission it would not go anywhere either.


You found it indeed, Mike. Many thanks!!! I just had a perfect RTL.

I am still building my copter (reprogramming RC, adding FPV, making it lighter,learning to fly, …) and never tried auto mission. I hence never changed WPNAV parameters (knowingly) and hence never checked whether they got changed… I should have done this…

Any tools around that allow to quickly compare parameter settings from multiple logs?

Thanks again!


Although I am flying 3.4.5 I have the same problem. I can fly an auto mission but it just will not RTL. It stays hovering above the RTL position and never lands. What should these parameters be set to?

I too have had perfect RTL results before the latest firmware upgrade so the parameters must have changed them.

Thanks in anticipation.

I’ve made some parameter changes but here is my parameter file:

Parameters as at 20 May 2017.param (11.0 KB)

Actually the Flight log has more information in it. It will tell me what you did and what mode it was in. If you can provide the flight log that would be great. It also has your parameters in it when it flew.

My log files won’t load as I think they are too big. I fly another auto mission alone and upload that log file. Thanks for your interest.

My parameter file for the flight however is here: 2017-05-20 16-15-37.log.param (10.9 KB)

Ok, here is my log file just flown:

2017-05-21 14-48-23.bin (2.9 MB)

I let the heli fly the mission and then left it to RTL. I did move the throttle stick to minimum and then to max and back to min so you will be able to see that. Eventually the heli went into loiter - I’m not sure why. I landed it in loiter.

Hope you can help. I previously flew RTL brilliantly every time. Now it just wont cooperate.

Parameter file for what its worth:

2017-05-21 14-48-23.log.param (10.9 KB)

I can’t figure this one out. It comes back home and then doesn’t land. I’m not a Heli person so it may have something to do with that.