RTK using Ublox evaluation kit

Hi,
just want to know if anybody does this so far.
Looking to buy the C94-M8P evaluation board from ublox to get a second gps on my Pixhawk.

Is this working with either Mission planner and pixhawk?

So, i got my kits from Ublox.
For a first try I used the build in radio modules which are the same i use for telemetry. Basicly a HM-TRP running sik firmware.
As a standalone solution the modules work like a charm. I get really fast rtk fix solutions in the open field. Accuracy of the Survey-In is well and the time to RTK-Fix for the Rover is, with the corrections already sending, like 2 minutes from power up.

The integration with pixhawk is some totally other stuff. My plan was, according to the manual from ublox, to shut down the onboard radios of the board with pulling high the according pin at the J8 header. After that i powered the board from the Serial4/5 connector. Connected serial 4 tx and rx to the board, set baud rate, and hoped it would auto-configure. But as it looks it is not this easy.
The GPS wasn’t discovered by the pixhawk.

Could anyone provide the messages i have to feed the pixhawk, if i only wan’t to use the RX Line from the pixhawk? could use the onboard radios instead of the inject gps option. But still need to make the connection and the messages…
Anyone here to help?

Hi Niels
I’m facing the same problem! Did you finally connect the pixhawk to the C94-M8P? I’m trying the same but with no success. I have connected as follows: GND (PX)–>GND(C94), Vcc (PX)–>Vcc(C94), Rx (pin 3 of GPS PX) --> pin 10 (Tx) of J8 of C94 and Tx (pin 2 of GPS PX) --> pin 9 (Rx) of J8 of C94. Is this O.K.? Why it is not recognized by the PX? I have set up the correct BAUD. I tryed also Serial2 and Serial4 to connect it as a second GPS but nothing! Did you finally solved it? Did you make any changes in the MP parameters? Can you please reply me at ioanxeno@gmail.com ? Thanking you in advance

I have worked extensively to get the C94-M8P working with Pixhawk and have it working flawlessly now but boy, did I struggle for a while!

A couple of things to note:

  1. The C94-M8P base to rover RTK (RTCM3) communication uses the serial transmit on the base’s M8P and serial receive on the rover’s M8P. So, there is no way for the Pixhawk to talk to the M8P. If you connect the Pixhawk transmit to the M8P, you will be clashing with the RTK comm taking place on the same line. So, you cannot connect anything to the C94-M8P J8 pin 9 or pin 14 IF you are using the built-in 915 MHz radios. Another small thing: I am using J8 pin 13, not pin 10, but either should work (refer to schematic of C94-M8P).

  2. Baud Rate: The Pixhawk tries to set up the GPS it finds on either the GPS port or Serial 4 by sending it commands. Since the C94-M8P will not recieve those (because of #1 above), we just have to have our board set up the way the Pixhawk WOULD set it up if it could. I hope that makes sense. AND I found, using a PC with a serial-to-USB adapter to snoop on the lines between a more standard GPS (ublox M8N) and the Pixhawk and then between the C94-M8P and the Pixhawk, that even with the baud rate set to 19,200 in the config in Mission Planner for Serial4 on the Pixhawk, where my C94-M8P was connected, the Pixhawk was sending out 115,200 baud. So, it must be expecting the GPS to default to that. So, you have to have that baud rate coming in. I tried a couple of things, but eventually disable the onboard radios of the C94-M8P and went with a LoRa solution.

The draft at Using U-Blox C94-M8P with Ardupilot on a PixHawk Rev 2 gives some info on the above. Also, my YouTube channel (https://www.youtube.com/channel/UCkIJQFyZdzLKh7AR-m3t2Bw) might help you. I am still a newbie and benefiting from this forum so much. I hope I can give back a portion of what I am finding.

You might read this thread as well:

I will be happy to share code, etc. if you decide to go with the Adafruit Feather M0.

I look forward to hearing how your project is going.

Solution to #1 is to connect Pin 20 to the Capacitor C9. Just check the Manual on Page 45. Just stumbled upon that. Either do this little soldering or just pull Pin 20 to 3v which is exactly the same with the soldering and wiring. My first attempt was to add a 3v step down in between pin 1 & 3 and the output to pin 20… works the same
If the radios are disabled the UART1 Port from the M8P is open to use.

Thanks for pointing that out. I did that (Pin 20 to C9), but had forgotten that I had, until you mentioned it! I disabled the radio that way, then connected the transmit out of the M8P BASE to its LoRa module (Feather M0). The receive of the M8P ROVER is connected to its LoRa module and the transmit of the M8P ROVER is connected to the Pixhawk receive. All set at 115,200 baud. I need to update my instructions and repost that document I link above.

Also, there may be a slight bug somewhere in my Feather transmit routine. That feather will lock up (or get stuck in the transmit loop) every now and then. It might run for days before it happens. I have thought about trying to implement a watch dog timer to reset it if something like that happens.