RTK gps on a budget (Quectel LC29HEA)

I’ve received the latest firmware (V1103S/2024-01-17) for LC29HEA, but inofficially from another user on their community forums. @Tobik I’ll share it with you in a direct message, and with anyone else interested, but I’ll hold off sharing it publicly until I get approval by some Quectel rep since it’s labelled confidential and I don’t want to start off on the wrong foot.


Excellent - looking forward to hearing about your experience with it.


I’ve just got round to it and ordered some. I’m curious to see if and how they will perform with NTRIP compared to the u-blox ZED-F9P GNSS modules.



SkyTraQ make some interesting chips as well.
Products (skytraq.com.tw)

NavSpark has a couple of dev modules with SkyTraQ chips on them.
PX1172RH-EVB : PX1172RH L1/L2 Position & Heading RTK Evaluation Board - NavSpark Store (mybigcommerce.com)
PX1172R-EVB : PX1172R L1/L2 RTK Evaluation Board - NavSpark Store (mybigcommerce.com)

The PX1172RH has two antenna inputs and gives heading from a single module.
I haven’t tried any of these but when I came across them, I bookmarked them for later research. Currently I’ve been using the ZED-F9P.

1 Like

I made a post about skytraq receivers a while ago.

@geofrancis I saw your post before I opened my thread, but the shop got a 65$ shipping fee to Germany, so it was no cheep option for me.

1 Like

Just a general tip for ordering from Chinese/Taiwanese stores, it often helps to contact them directly if there’s something preventing you from ordering (high shipping fees, payment issues, product out of stock…). They can be surprisingly helpful in finding ways to make it work :slight_smile:


@Tobik that shipping cost is the only reason i dont own more of them.
@Oli1 The skytraq was coming from the US and shipping was more than the GPS module itself.


Hi, does anyone have an idea what adjustments I should make in Ardupilot to make this module work?

Why the location is in 10 points?

If it’s outputting NMEA and it’s connected correctly, it should be detected automatically. You need to share more details other than screenshots (like the exact hardware in use + a parameter file).

That’s a geofence.

My hardware: speedybee F4 V3 and LC29HEA connected to uart 6. My parameter file:
Param list LC29HEA.param (15.8 KB)

I suspect a wiring problem. Your parameters look like they should work. Be sure you have connected TX to RX and vice versa.

1 Like

the wires are connected correctly :frowning: I’m running out of ideas what could be wrong


I haven’t tried it, but there’s a Serial Passthrough you can use


You should then be able to see/watch the traffic coming out of the GPS and into the serial port in another program, and examine the traffic.

If nothing else, the RTKNAVI from the RTKLIB (or rtkexplorer’s version of RTKLIB) will show you the GPS traffic as NMEA messages.

That would confirm that you have the wiring correct, it’ll help you verify you have the baud (really bps) correct, and that it is putting out NMEA sentences.

1 Like

Hi Tobias,

Nice to talk to you. This is Lina from Unicore.
Glad to know you are working on a robotic lawn mower project, if you are interested, Unicore UM960 is a very suitable RTK module for applications like robotic mowers where there are bloack like tree shade, bushes, etc.

Please feel free to ask any question zhulina@unicorecomm.com

Kind regards,

I’ll send you the latest firmware via DM. Flash, and set the update rate to 5Hz with the $PQTMCFGFIXRATE command (on the module, that is). How exactly, you need to find out yourself since nobody here has gotten their hands on the actual module yet :slight_smile:
In Ardupilot 5Hz should already be the default setting, but double check: GPS_RATE_MS: 200

1 Like

Adding some more information for the LC29HEA, courtesy of the very helpful u/bamarcant over at the Quectel Forums!

I add these useful commands for module debugging:
$PAIR003*39 disable gnss so output in terminal is blanc for read only command response
$PAIR002*38 enable gnss
I use sscom with a partial english translatet gui: 445.5 KB folder on MEGA or http://www.daxia.com/download/sscom.rar
as have difficult to send commands by Qgnss.
Other useful information : Configuring the Quectel LC29HEA receiver for real-time RTK solutions – rtklibexplorer

10 Hz = 100 ms 2 Hz = 500 ms 5 Hz = 200 ms 1 Hz = 1000 ms

$PQTMCFGFIXRATE,R*71     Queries the setting of current FIXRATE
$PAIR513*3D  & $PQTMSAVEPAR*5A  save parameters
$PQTMRESTOREPAR*13  restore default

$PAIR432,1*22 set RTCM3.x output with type MSM7 $PAIR432,* -1 rtcm_dis , 0 rtcm_4, 1 rtcm_7
$PAIR433*3E Queries the setting of rtcm_MSM current ouput
$PAIR051*3E Queries the setting of $PAIR050,<Time>*<<Checksum>
$PAIR864,<Port_Type>,<Port_Index>,<Baudrate>*CS<CR><LF> i.e 115200, 230400, 460800, 921600, 3000000
$PAIR865,0,0*31 Queries the baud of uart_port and response.

(Not sure if this applies to all boards, but good to keep in the back of the head anyway:)

To operate the reset command (for the fw upgrade) on Mozihao boards, you need to ground pin_8 manually only for few seconds until qgnss_flash_tool_upgrade says ok , as the RST_ttl pin is not connected,I used the probe tester.


Does anyone have GUNS app v1.10? I can’t register on the site.

I’ll send you the firmware package per DM, QGNSS 1.10 (I think that’s what you mean…) is included.

1 Like