RTK/GPS Inject" is not available in MissionPlanner-1.3.78 or later

Hello. I am currently experiencing an error when connecting to RTK-GNSS from MissionPlanner.

After v1.3.78 of MissionPlanner, it’s no longer possible to retrieve RTK-GNSS reference station data from RTK2go and other NTRIP casters from the “RTK/GPS Inject” window.
I installed the latest beta version to resolve this, but still could not solve this problem.
I have the same problem with the Android version of MissionPlanner.

I’m currently using MissionPlanner v1.3.77.
And in that case I’m getting RTK-GNSS reference station data without any problems.

Is there a fundamental solution to this problem?
Also, does your development team know about this problem?

Thanks to all of you who have checked this page.

Both RTK2Go and Mission Planner have had somewhat recent (past 6-9 months) updates that require slightly different string formatting than previously worked.

Your connection string should look like this:

1 Like

Thank you for letting us know!

I have tried connecting to the RTK-GNSS base station according to the input format you gave me, both with v1.3.77 and v1.3.78 or later of MissionPlanner.
But the error still remains the same.
We still couldn’t connect to RTK2go with v1.3.78 or later of MissionPlanner.

I’m using 1.3.80 (beta) without issue.

1 Like

Thanks for sharing the information!
I reviewed the URL I typed in many times.
And I was still able to connect with RTK2go in MissionPlanner v1.3.77.
I followed exactly the URL format you gave me, and it worked in v1.3.77 and not in v1.3.80(beta).

Also, I have two different PC’s and the same thing happened on both of them.
I believe that MissionPlanner since v1.3.78 may have changed the specifications regarding “RTK/GPS inject”.
I hope the developer will get this issue.