RTK base com port connection error

Can somebody please help with a RTK com port connection error that I’m getting?
I’ve had RTK here+ base connected to a Windows 10 Laptop for a couple of days and it’s been working fine on com port 10. Then this morning on connecting I get this message “Error connecting”. It doesn’t see com port 10 anymore in the drop down box next to the green connect button. I haven’t made any changes to the laptop.

A few of things that I have tried:
Updated Mission Planner to latest beta, didn’t fix the error msg.
Uninstalled MP and reinstalled older version, still get the error.
Tried a 2nd RTK base on this windows 10 laptop and it produced the same error.
Change the sample rate which didn’t make any difference.
Installed U-Blox U-centre (VCP) and can connect to Here+ on com port 8 and it works fine/ can see all sats working.
Win 10 laptop has the latest drivers.
Mission Planner sees RFD900 radio modem on com port 4.
Tried it on old Win7 laptop, initially had the error but then updated Mission Planner to latest beta and now works fine.

Nearly drive a man to drink!

Appreciate any help?



try changing the comport name in device manager.

I’m wondering if com8 has a conflict somewhere.

to change it
open device manager > properties on the device > port settings > advanced > com post number.

Thanks Michael but no luck with com port name change.

Manage to find/solve my com port problem.

Dive Manager>sensors>U-blox GPS antenna>drivers>roll back driver.

In MP RTK page, com port 7 appeared.

It’s now working a treat!