RSSI wrong measures with Pixhawk 2.1 and LRS Thomas Scherrer rx

I keep trying to set RSSI with Thomas Scherrer rx (analog RSSI) and Pixhawk 2.1 Cube.

First issue, rx manual says RSSI voltage should be between 0.5v to 3.3v (from min to max). I put a voltage tester in parallel and this shows 1,90v to 2,10v from min to max (very low resolution). The servo rail is fed by the ESC at 6v linear, if I change the power supply to 5v, the RSSI voltage also changes.

Second issue, later I set Pixhawk like this:
RSSI_TYPE: 1(analog port)
RSSI_ANA_PIN: 103 (sbus out)
RSSI_PIN_HIGH: 2,1(like tester max reading)
RSSI_PIN_LOW: 1,9 (like tester min reading)

But HUD RSSI value showed 0%. I did a test and set RSSI_PIN_HIGH: 6 and now seems to be reading RSSI values because HUD showed 88%. I made some test to get correct values so RSSI_PIN_HIGH: 5.25v (RSSI HUD 100%) and RSSI_PIN_LOW: 5.15v(RSSI HUD 5%)

The same happens with a second Thomas Scherrer receiver like the first one.

I can’t understand why the voltage measeured by tester is not like manual says for RSSI, and why RSSI parameters set up in Mission Planner are not like values measured by voltage tester.

Hello tucuman,
I had the same experience. My voltage parameter settings in
arducopter 4.0.3 are
RSSI_PIN_HIGH: 4,86 (99%) voltage tester: 2,02V
RSSI_PIN_LOW: 4,08 (2%) voltage tester: 1,22V
arducopter 3.6.2 are
RSSI_PIN_HIGH: 1,95 (99%) voltage tester: 2,02V
RSSI_PIN_LOW: 1,625 (2%) voltage tester: 1,22V

Have a Good Flight