Servers by jDrones

RSSI_TYPE, 5 on Matek F765 board but rssi do not show up

Hello,

I have set up the RSSI parameters in Mission planer according to the wiki
( https://ardupilot.org/plane/docs/common-rssi-received-signal-strength-indication.html )
Using a pair of RFD900x units, both the fields SiK Radio RSSI and SiK Radio remote RSSI show values around 240, however the rxrssi- field in the HUD always show 0.
The rssi_type is set to 5, TelemetryRadioRSSI.

On my Boat (Ardurover) with a Kakute F7 AIO board the rxrssi -field is showing nice % values using the same setting.I have compared settings and cant find any obvious difference.

What can I be missing?

This issue might not seem a big deal but it means there is no RSSI in OSD flight and that’s one of the precious few values in FPV I think.
I will try to upgrade to dev version of Arduplane, but really don’t know what to check after that.

Yesterday, the rssi data suddenly started to work, (Missionplaner hud field rxrssi).
This is good news but I am not aware of any changes to relevant settings (RSSI_TYPE etc).
I noticed it was working when trying to calibrate an unhealthy compass and made several reboots of the board. also got a gps 3d fix.
Anyway, I will not ponder about why but just move on in life :smiley:

Servers by jDrones