RSSI Pixhawk PX4 & FrSky X8R Receiver

It’s that thorny old problem that so many pilots have trouble with - getting RSSI to work!
So, I have a Pixhawk PX4 and FrSky X8R Rx and Taranis X9D Plus Tx.
This is what I have done so far:-

The X8R RSSI is connected to the PX4 SBUS out port. In the following configuration I have tried using a normal servo lead, and one I modified with an RC network.

In Mission Planner 1.3.41 APMCopter V3.3.3

Parameter: RSSI

RSSI_PIN 103 (no options for this)

Parameter: BRD

BRD_SBUS_OUT (3 options for frame rate: 50Hz, 75Hz & 100Hz, all tried with no success).

I re-booted the PX4 after every change.

I cannot obtain any RSSI output. I have measured the voltage output of the X8R when connected to the PX4; with the Tx on it measures 3.19V max, Tx off it measures approx 40mV. Clearly, the X8R is outputting RSSI values.

The MinimOSD (connected to Telem 1) always shows 0% RSSI. I also ran QGroundControl v2.9.4, which has an RC RSSI facility; this too always shows 0%. It appears then, that the Telem 1 port is not outputting RSSI data.

Is there something I have missed, or is there a fault in the PX4?

Assistance with this would be hugely appreciated. Thanks in advance.


Hexa version 3.4.3 has all the RSSI parameters now, which work.
Thank you dev team, its appreciated.