RSSI only showing 0% or 100%

Hello, I’ve been having a lot of problems on arduplane 3.8 to get rssi from my dragonlink.
I used to put a wire between my rx and pixhawk like with the APM which worked great, however on my new config, I decided to get rid of the cable and setup my dragonlink rx to output rssi on channel 8 within the ppm stream.(my flight modes are on ch5)

In Mission Planner, I correctly configured rssi_chan=8; rssi_type=pwm; min_pwm=1916 max=1992.
I f I check in radio calibration, I can see this channel moving constantly like it should, however when I look in the Quick view datas as well as on my osd, the rssi is 0% when radio turned off, and 100% when turned on, there is no middle value.

I could just plug the cable back but I’m to frustrated from not making such a simple thing work.


While it my be a typo, you need to have min_pwm equal to something like 1000, not 1916.

DragonLink’s RSSI does not behave like a real “RF” type RSSI value. DragonLink’s RSSI is actually the result of a calculation that includes some aspect of data quality as well as the received signal strength. It generally does not begin to reduce from its 100% value until several miles out - only then does it begin to reduce by the usual 6dB each time the distance is doubled.

Try unscrewing the transmitter antenna and you should see a value between zero and 100. Put it back quickly lest you damage the transmitter.

Good luck,


Hi, yes indeed it is a typo it’s 1092 as min.
As for the DL signal, it definitely isn’t the explanation, because first I was out several miles yesterday with 100% (I usually go down 65% ln this route I usually fly), and also I tried unscrewing the antenna in the 25mw mode of my transmitter, I can see the channel in radio cal moving as it should but no the rssi.

Also, this is a fresh new firmware install because of other problems. On my previous install it simply didn’t even work at all…

Thanks for your help

Do you have Arduplane rssi_type=2 (rcchannelPWMvalue)?


(The text has to be 20character minimum)

DragonLink may have done something new with the latest software (Nov26) than what was before.

I am a new DL user and began with the Nov26 release - I thought rssi wan’t working until the RCG forum feedback said to expect the special DL presentation of what they still call rssi.


Hi, the thing is since the channel moves correctly in the radio calib page I really believe that the problem is coming from arduplane and not DL.

What channel are you using for rssi ?
Also, can you see the rssi move live on the quick view page of Mission Planner ? Because on mine, even if I turn off the transmitter I have to switch back and forth from another tab to see the rssi go from 100 to 0

I am using channel 8 and tell the Pixracer with Arduplane 3.8.3 to look for the RSSI on channel 8.

I never looked in the quick view page, but I can see the channel 8 PWM value move from 100 to 0 and back to 100 (ish) again on the status page when I turn the transmitter off and then back on again.

Did you change the SR1_RC_CHAN parameter to 1? Noircogi’s DL/MP instructions say to put it to zero (0), but he uses an OSD. For Mission Planner the parameter has to be set to 1.

Hi, I just reinstalled MP with a new version and it seems to work for the moment.
Very weird but go figure sometimes.

Anyway thanks a lot for helping me.


Ok, excellent. Good luck and may the software gremlins lay low while you are in the air.