RSSI not showing in MinimOSD

I am using Pixhawk and connect rx RSSI to S.bus pin. I tested rx RSSI pin did give a 3.3 to 0V . I used minim OSD and tried different versions of CT and firmwares starting v2.2 and extra and higher versions. Still I cannot have the RSSI (not even the RSSI icon, not to speak the value) displayed onthe OSD screen. Anyone have the same experience or have success in showing RSSI? Apparently the plane version works ok, it is the copter version have problem. Need help please !!

You’re using Copter-3.3? … and you’ve tried loading Plane on the board and it does work?

Hello, I have mine working fine with arducopter 3.3-rcX .

My setup is composed of:

Minimosd ( 2.2 extra ) )
Frsky d8r-II plus ( with D8r-XP fw )

For frsky rx to work you need a special cable connected to port 2 on rx to Pixhawk sbus

On ardupilot, make sure those parameters are set accordingly:

RSSI_Pin = 103
RSSI_range = 3,3 ( or 5v depending on RX )

You should also be able to watch your RSSI shown up in mission planner, by right-clicking on hud -> user items -> RXRSSI checkbox

If the value is displayed inside mission planner, it is definitely a minimosd issue. If it’s not, it could be an issue with pixhawk setup/wiring.

What is your setup ? Could you explain your wiring and send your parameters and a screenshot of minimosd config ?