Servers by jDrones

RSSI new configuration

Hi,

i´m having some trouble with the new RSSI configuration.

With the version 3.3 the parameters that I have was:
RSSI_PIN - 103
RSSI_RANGE - 3.3
And it work just fine.

Now with the version 3.4 I´m having trouble making it work.

I have the 3DR Pixhawk and a DragonLink receiver.

Any help will be appreciated.

Thanks

What do you have for the other rssi settings? and what is the rssi signal being sent from the dragon long, analog or pwm over an rc channel?

Ie, on my D8R I connected to the sbus out I have -

RSSI_ANA_PIN,103
RSSI_CHAN_HIGH,2000
RSSI_CHAN_LOW,1000
RSSI_CHANNEL,8
RSSI_PIN_HIGH,3.8
RSSI_PIN_LOW,0.2
RSSI_TYPE,1

That tells it to say type = analog pin which is 103(sbus out) and defines 100% rssi as 3.8v and 0% rssi as 0.2v

I want to input FrSky RSSI that is PWM format.

DO I just set RSSI_CHANNEL to 8 and plug the cable into the RC servo channel 8. Then I power it up and see what the PWM readout is when the transmitter is close and when it is off and enter that in the high/low parameters.

Where do I look in the MP to read out the PWM values?

.

If you have a pixhawk then no more cabling is required as the receiver will be sending all the rc channels to the pixhawk through ppm. If you have an apm then yes, you will need to connect the receiver’s channel 8 to the apm’s channel 8 input.

Then, if you set -

RSSI_TYPE,2
RSSI_CHANNEL,8

Then look in the HUD on mission planner and choose the status tab, you can see what the channel 8 value goes to with the transmitter on and off.

Then you set

RSSI_CHAN_HIGH, to the pwm at 100% rssi
RSSI_CHAN_LOW, to the pwm at 0% rssi

Obviously this is only valid for plane v3.4

As far as I’m aware that should work, only used the analog pin from my d8r.

Sorry but that’s a very confusing answer for my. I have a Taranis Plus transmitter with FrSky receiver. I have the Pixhawk connected to the Sbus connector and everything works perfect. The PWM RSSI comes out of the receiver on a separate connector. Sounds like you are saying that I will have to inject that signal into the Sbus stream. I don’t think that’s possible.

I was expecting that I would just run a connector between the receiver RSSI out to channel 8 on my Pixhawk. If that won’t work them the new firmware is useless for all Pixhawk users that use Sbus. There must be some solution that I am not seeing.

.

The problem is you’re saying frsky receiver but not which one.

Pixhawk has the rcin which uses ppm/sbus from the receiver for the rc channels, there are no other inputs besides the sbus output. You can’t connect a signal to the pixhawk using pwm except via ppm encoder or ppm or sbus. Everything to the side of the sbus out are all outputs only.

As for the new firmware being useless that’s a bit ott, I use v3.4 on a Pixhawk with my d8r-xp connected via ppm/sbus with rssi connected to the sbus out port on the Pixhawk with this filter - fpvlab.com/forums/attachment.php … 1370194266 - and it work’s perfectly.

I have the X6R receiver set to the 16-channel mode. I have added an external RSSI wire. rcgroups.com/forums/showpost … ount=45794

I am currently using the filters on my airplanes but I was hoping to upgrade to direct RSSI PWM input.

Why can’t you write code to accept PWM RSSI into port 103?

Are there any receivers that put RSSI out to the Sbus?

.

RC Mike:

At the moment, there is no way to get RSSI from the FrSky X4R/D8R SBUS receivers without using an analog filter, as suggested by others above.

But to answer your question, I actually have had a patch ready to go for some time now to get a kind of RSSI value out of an SBUS receiver by counting dropped frames. This requires no extra cabling and performs quite well in my experience.

github.com/diydrones/ardupilot/pull/2798

The patch has been waiting for review for several months, and finally recently I got a bit of feedback. I’m working right now on a re-submit. Stay tuned.

That’s exactly what all of us Sbus users need. Now we will be able to get RSSI type information even with receivers with no RSSI output. I am looking forward to using that in the future. Thanks for all the good work.

.

I’ve gotten the SBUS link quality RSSI patch ready again. You can find it here:

github.com/diydrones/ardupilot/pull/3274

For those that would like this, it never hurts to post a brief comment on the above thread expressing your opinion.

Thank´s MArkM

It work just fine with your setup:

RSSI_ANA_PIN,103
RSSI_CHAN_HIGH,2000
RSSI_CHAN_LOW,1000
RSSI_CHANNEL,12
RSSI_PIN_HIGH,3.3
RSSI_PIN_LOW,0.1
RSSI_TYPE,1

I tried other RSSI_Channel and all worked :slight_smile: it seams that all is coming from the SBUS. If that is the case why we need to use the RSSI_ANA_PIN value of 103? And why the use of the RC_IN pin connected to the receiver?

Setting RSSI_TYPE to 1 means RSSI_ANA_PIN, RSSI_PIN_HIGH and RSSI_PIN_LOW are used.
Setting RSSI_TYPE to 2 means RSSI_CHAN_HIGH, RSSI_CHAN_LOW and RSSI_CHANNEL are used.

If you have RSSI_TYPE as 1 then I’m not sure how you are getting RSSI at all as that setting is telling the plane firmware to use the analog pin for it’s RSSI information.

If you have RSSI_TYPE as 2, then the plane firmware will be looking at channel 12 on the rcin port for the RSSI info which will work if your radio receiver can be configured to send RSSI information on channel 12.

I tried with my Thomas Scherrer receiver but doesn’t work. This rx has analog Rssi output with 0.5 to 3.3V from min to max.

My parameters are:
RSSI_ANA_PIN,103
RSSI_PIN_HIGH,3.5
RSSI_PIN_LOW,0.5
RSSI_TYPE,1

The rssi rx output is connected to sbus out in my Pixhawk 2.1

Can anyone help me please? thank you!!!

Servers by jDrones