Servers by jDrones

RSSI_channel not visible in Tower app

I am using an APM 3.1 connected to my ezuhf receiver via cppm. I can’t find rssi_channel in the list of parameters that I can download from my APM. I’m on arduplane 3.4.2, so I believe I should have it, but all I can see are the rssi_pin and the rssi voltage parameters.

I have my ezuhf set to output RSSI on channel 7 (channel 8 is being used for flight modes). I was hoping the solution would be as simple as connecting the channel 7 servo output to the A0 or A1 pin, and then setting RSSI_pin to A0 or A1, but of course that would have been too easy - it doesn’t seem to work either.

I used the Tower app to download the parameters via 915MHz telemetry radio. Might I not be getting the full parameter list?

I’m in contact with Leagle Eagle via email, and he tells me he has an APM, and not a Pixhawk or other APM successor flight controller. Unfortunately the improved RSSI via channel features did not make into the last release of ArduPilot for APM, so this feature is not available for APM. I know others beside Leagle have been confused by this, so I wanted to mention it.

I suggest this issue be closed.

Servers by jDrones