RPLIDAR A3 is not working connect TEL1 (no rotating)


i`m follow this page:

RPLIDAR A3 is not rotating.

Is there anything I missed?

1 Like


not rotating motor problem :

When not connect anything 5V power is out (serial1, TEL1) but RPLIDAR A3 connected, power is dead.
when once power is dead, not output power after. then reboot FC, power is out (not connected anything)

so solved external power source 5V (use BEC or something).
RPLIDAR is rotate.

other problem is occur.
not communication FC and RPLIDAR A3.


RPLIDAR A2 is buad 115200, but RPLIDAR A3 is 256000.
default FC buad is not support 256000.
so change source code.
my case serial1 buad (111, 111000 -> 256000).

after working !

Hi, I am experimenting the RPLiDAR A3 too and facing the same problems.
Can you share the parameters?
How is your experience so far on the A3?



i`m sloved problem.

A3 baud is 256000 …250000? i don`t know … anyway

pixhawk default serial baud is not exist same A3 baud.

so need modify arducopter source code baud.

example - (in my case)

serial 1 baud

111 - 111100 (default)

  • 256000 (modify source code)

then i`m changed serial 1 parameter.

Serial1_baud - 57 (57600, default)

  • 111 (111100, modify)

and RPLIDAR is need external 5V.

on pixhawk serial port power is not enough.

so i`m used external power 5V. (BEC)

and then it worked !

if you have question, please send me e-mail on other address.

this address is don`t use.


2019년 3월 5일 (화) 오후 10:34, Ernst Thijsen noreply@ardupilot.org님이 작성:

and my firmware is hexa copter.

it is ok to you?

source X
parameter O

Have you any problem in use RPlidar A3 in outdoor and sun light ? How long this can identify obstacles ?

I think use this in agricultural spraying quadcopter !

Thank you soo much

did u sort the issue?