RPLidar A2 360 in Rover

Hello all. I have a problem with the rplidar a2 360 configuration. It seems that lidar works correctly, but the controller does not interpret it correctly. In other words, the vehicle does not avoid obstacles but strikes. Did any of you configure lidar 360 with a pixhawk controller. I am using a pixhawk2 controller with GPS. In autonomous mode, the vehicle does not react to obstacles. In steering mode, the vehicle stops after detecting an obstacle but can not avoid it. For me it is important that the vehicle avoid obstacles in AUTO mode. It looks like I can not handle the right setting. Can any of you help me or suggest something? Below I’ve posted a link where you can find parameters and logs.


I may be wrong, but RPLidars do not seem to be supported as rangefinders in ardurover, only as proximity sensors. So the advanced object avoidance does not work with a RPLidar. Only stopping in front of an obstacle in acro, steering and guided mode and not in auto mode.
The demonstration video @rmackay9 posted, also only shows stopping in front of an obstacle with an 360° lidar.
Perhaps he can clarify this.

Assuming lidar, I had high expectations for passing obstacles through the vehicle. So I have to understand that lidar 360 is not better than a solid sensor like eg sonar or lidarlite? In the mission planner by clicking the proximity you can see that lidar 360 detects obstacles on each side and shows the distance. Can not use this?

Right now ardurover can only use the 360° sensor to stop in front of obstacles, but since ardurover is in constant (and much faster than it once was) development, I would bet this is not the final state. The rangefinder obstacle avoidance is the older version of avoidance only used by ardurover, while, as far as I know, the proximity sensor avoidance came from arducopter. There are still parameters like “max lean angle” in ardurover for proximity avoidance, which do not make a lot of sense for a rover. For some reason it is possible to use a rangefinder as a proximity sensor, but not the other way round. At least I did not get it working this way…

I am very grateful for the detailed explanation of my problem. And if I use lidar 360 to avoid obstacles in the copter, will it work in all directions or just like in a rover? I do not see the point of leaving lidar 360 in the rover if you can not use its possibilities.

Obstacle avoidance in auto and rtl does not work in arducopter, either. It is harder to do than in ardurover, because the copter can move in 3 dimensions. For a rover 2d data is almost (ledges and obstacles that pass below the sensor might still be a problem) all it needs, but for a copter it means a lot of space without any sensor data.

If you can, tell me which sensors to use so that I can use obstacles in most cases in auto and rtl mode. Buying lidar 360 and not be able to use it strongly disgusted me.

I use a Benewake TFmini on my rover. With this sensor the advanced obstacle avoidance is working. I have ordered a second TFmini, so the rover knows in which direction it should turn to avoid obstacles. With one sensor it always turns in the same direction. I still have to find the right upward angle/debounce setting combination for the sensor, because I am getting false readings from the ground in front of the rover.

I understand that you were able to configure these sensors in such a way that the vehicle detects obstacles in auto mode and continues to avoid. Which connectors did you use for connecting? What type of range sensor did you choose in the mission planner? If it works, I buy two of them right away. I found one at my place in Poland. https://botland.com.pl/skanery-laserowe/10198-laserowy-czujnik-odleglosci-lidar-tfmini-uart-12m.html?gclid=EAIaIQobChMIq-Wbk8XG3QIVbb7tCh185Qd8EAAYASAAEgK3gPD_BwE