RPi mavproxy link but 'mavserial' object has no attribute 'calibrate_imu'

Raspberry Pi 2 + mavproxy 1.6.1+ APM Copter 3.5.0

when i link the pixhawk haedware display this

  • APM: APM:Copter V3.5.0 (633501f9)
  • APM: PX4: 33825946 NuttX: 1a99ba58
  • APM: Frame: QUAD
  • APM: PX4v3 00210033 32355108 37313937

i have tow probelms

1:
when i “ground”,it’s bad

  • STABILIZE> ground

  • STABILIZE> ERROR in command []: ‘mavserial’ object has no attribute 'calibrate_imu’
    2:

  • when i “takeoff 3”

  • STABILIZE> Got MAVLink msg: COMMAND_ACK {command : 11, result : 0}

  • arm throttle

  • STABILIZE> Got MAVLink msg: COMMAND_ACK {command : 400, result : 0}

  • arm throttle

  • STABILIZE> Got MAVLink msg: COMMAND_ACK {command : 400, result : 0}

  • ARMED

  • Arming checks disabled
    *** STABILIZE> takeoff 3**
    *** STABILIZE> Take Off started**
    *** Got MAVLink msg: COMMAND_ACK {command : 22, result : 4}**

  • STABILIZE> DISARMED

  • STABILIZE>

how can i solve the problem, thank you

Could you use the command set moddebug 3 in MAVProxy and run those commands again? That would assist in narrowing down issue 1.

For issue 2, I am getting the same issue in SITL. I’ll investigate and see what I can find.

thank you
for issue2,i use QGC also can not “takeoff”,but i can arm

for issue 1,i “set moddebug 3”,then “ground”,

  • STABILIZE> ERROR in command []: ‘mavserial’ object has no attribute ‘calibrate_imu’
  • Traceback (most recent call last):
  • File “/usr/local/bin/mavproxy.py”, line 492, in process_stdin
  • fn(args[1:])
    
  • File “/usr/local/lib/python2.7/dist-packages/MAVProxy/modules/mavproxy_calibration.py”, line 28, in cmd_ground
  • self.master.calibrate_imu()
    
  • AttributeError: ‘mavserial’ object has no attribute ‘calibrate_imu’

i find this code,but i have no idea to solve it
sorry,i can not use English correctly

when i “ground”,it’s bad

  • STABILIZE> ground
  • STABILIZE> ERROR in command []: ‘mavserial’ object has no attribute
    ’calibrate_imu’

Ok, that one’s easy. “Don’t do that then!” :slight_smile:

The command called in the pymavlink project to do that was removed in
2014. We just don’t seem to have removed “ground” from MAVProxy - if you
felt like putting together a PR to do that, that would be nice :slight_smile:

2:

  • when i “takeoff 3”

  • STABILIZE> Got MAVLink msg: COMMAND_ACK {command : 11, result : 0}

  • arm throttle

  • STABILIZE> Got MAVLink msg: COMMAND_ACK {command : 400, result : 0}

  • arm throttle

  • STABILIZE> Got MAVLink msg: COMMAND_ACK {command : 400, result : 0}

  • ARMED

  • Arming checks disabled
    *** STABILIZE> takeoff 3**
    *** STABILIZE> Take Off started**
    *** Got MAVLink msg: COMMAND_ACK {command : 22, result : 4}**

  • STABILIZE> DISARMED

  • STABILIZE>

how can i solve the problem, thank you

takeoff only works in guided mode.

Try (starting in stablize):
arm throttle
mode guided
takeoff 3

for issue 2

  • STABILIZE>

  • STABILIZE> arm throttle

  • STABILIZE> Got MAVLink msg: COMMAND_ACK {command : 400, result : 0}

  • ARMED

  • Arming checks disabled

  • STABILIZE> DISARMED

  • STABILIZE> mode GUIDED

  • STABILIZE> Got MAVLink msg: COMMAND_ACK {command : 11, result : 0}

  • GUIDED> Mode GUIDED

  • GUIDED> takeoff 3

  • GUIDED> Take Off started

  • Got MAVLink msg: COMMAND_ACK {command : 22, result : 4}

  • GUIDED>
    i think the result :4 maybe have some means

  • ARMED
Arming checks disabled
STABILIZE> DISARMED
STABILIZE> mode GUIDED

There’s a timeout in ArduCopter which disarms the vehicle if you don’t do
something soon after arming. Work faster :wink: