rpi cm3+ for arupilot operation.

I am using navio2 and rpi by connecting them.
First, rpi used 3b+.
And I checked that it is working normally.
The image file in rpi is as follows.

Link: http://files.emlid.com/images/emlid-raspbian-20200922.img.xz

By the way, I would like to design a new rpi and use it.
So we proceeded with the design using the rpi compute module.
Before pcb was made, we tested the same item as dev kit on the link below.

Link: https://www.google.com/url?sa=i&url=https%3A%2F%2Fkr.element14.com%2Fraspberry-pi%2Frpi-compute3-kit%2Fraspberry-pi-compute-module-3%2Fdp%2F2675719&psig=AOvVaw0Uk_O8TGAr5ql8S_kGLhx-&ust=1612007029324000&source=images&cd=vfe&ved=0CAIQjRxqFwoTCKDk1riIwe4CFQAAAAAdAAAAABAK

And I tried using the sd card that was used in the rpi 3b+ by attaching it to the rpi cm3+.
But it didn’t work normally.
When I checked the gpiio to find the reason, the value of rpi 3b+ and rpi cm3+ were different.
The gpio mode was the same.
So I tried to adjust the value and it didn’t work.

So here’s the question.
Doesn’t the rpi 3b+ run the rpi cm3+ software?
I compared gpio of rpi 3b+ with rpi cm3+ gpio, but it turned out to be the same.
However, it does not work even if the gpio mode and value are the same.
Has anyone tried rpi cm3+ with an armpitilot?
I’ve tried many things, but they don’t work, so I ask you a question here.

There are many smarter people than me, so I’m sure you’ll answer.
Please check.
Thank you.