Rover with the groundsteering on the Ail channel

How do I move the steering to the Ail channel? On the servo output page I set the pin# to the RCIN# and everything works fine in manual mode. When I click auto mode, it just sits there and does nothing but I can still control it like it is in manual mode. Any other info you guys need or any idea what I’m doing wrong?

Use the RCMAP parameters.

Separately, the mode switch to auto is failing. You haven’t given enough info to determine why.

I just tried changing rc2_option to 53. Is this what you are talking about? If so, that didn’t work either. I do notice 53 just says steering but the dropdown on the servo output pages says groundsteering. Does that matter?

Please read the documentation:

There is no instruction there telling you to set the servo outputs to RCIN.

1 Like

No. These (possibly not exactly these settings, but these parameters):

It sounds like you aren’t following the setup guides very closely.

First Time Setup and Configuration — Rover documentation (
First Drive with Rover — Rover documentation (

Im still confused. I am trying to use Ail stick to control steering not rudder and the pitch for throttle (center is stop, push up for forward and back for reverse). Could you please tell me what the settings are suppose to be on the RCMAP? #1 in servo output is now is set at groundsteering and #3 at Throttle.

Set RCMAP just like the screenshot, and I think you’ll be there. Zero the RCx_OPTION parameters for those channels.

And please read the setup guides. They cover this.

Okay, I zeroed the RCx_OPTION and set my RC_MAP to the picture attached. This might have done it. I am having to charge my Transmitter now… but you can still check my work.

You’ll have to check your own work. I don’t know the mapping for your transmitter (there is no standard between manufacturers), but the screenshot I shared is a typical one for the control scheme you desire.

Your current config does not match what I shared if that was your intent.

Everything seems to work correctly except when auto mode. The steering turns by itself in auto mode but the throttle does not. The throttle works fine in manual mode. Any ideas?

I can only say the documentation is there for a reason. Please read and understand it.
There is no shortcut to a working vehicle.
Going from, “I have the outputs set to throttle and steering” to “Why does Auto mode not work” shows that you did not follow the documentation and left many (all) setup and tuning steps out.
I do not mean to be unhelpful and I know there is a learning curve, but it will all make sense eventually.

No, it shows that the documentation was written for someone who knows what they are doing and not for noobs.

If you assign the servo output to the RC input, you are skipping the autopilot altogether. This will only work in manual mode. RC inputs are only used in some modes so you can’t assign the servos to them directly. See the picture here: Simple Overview of ArduPilot Operation — Rover documentation

RC inputs need to be read into the autopilot using the RC map, it tells what RC receiver channels to assign to which manual control: RC Input Channel Mapping (RCMAP) — Rover documentation

The servo outputs need to be configured for what they are connected to, so the autopilot can decide whether to use the manual RC inputs in manual mode, or directly control them in autonomous modes. (Throttle, steering, etc). Motor and Servo Configuration — Rover documentation

Thank you!! I will reflash my pixhawk and start over just to insure I didn’t set some odd parameter somewhere.