Rover with 3.0.2 & Pixhawk needs steering modifications

Can anyone tell me where in the Pixhawk code, the RC channel PIN numbers for Steering and Throttle are defined?
On my Pixhawk, they are #2 and #3 , which BTW is not what the documentation says they should be.

I have 6WD Wild Thumper chassis which is currently running well.
I want to refine the steering control to be less abrupt by metering the throttle on the inside track/wheel set.
This metering I plan to do in code in the Arduino in the motor controller but may have to change code in the Pixhawk.

I have currently set it to SKID_IN as enabled.
Thanks for any help.

Are you saying on a skid steering rover rather then have it turn on the spot you want to reduce the throttle input on the inside wheel set so the rover move’s in a curve? This is an interesting idea and could be done with a percentage parameter that defined how much throttle to apply to the inside wheel when turning.
Regarding your pixhawk channel’s its almost certainly your configuration.

  1. Your transmitter sticks will output on a certain channel. This is configurable on your transmitter. So you could make the right stick up/down movement happen on ANY channel.
  2. The RCMAP_ parameters are what your looking for. This controls which input channel its expecting to see each input on. So in your case I suspect that RCMAP_ROLL is 2 instead of the usual 1 and that the steering stick on your transmitter is outputting on channel 2.

If you still want to read the code start with
APMrover2/radio.cpp in the Rover::set_control_channels

Thanks, Grant.

Yes exactly for the Skid steering idea. A bit of an algorithm in the motor controller should work.

As for the Pixhawk output PINS and my RC transmitter; EUREKA!
I finally get what is going on.
The transmitter Pitch and Roll channels are 3 and 2 respectively.
A test of Yaw on channel 4 with a modified RCMAP worked exactly.
Now a happy camper.


Glad to hear its working. Video’s of rovers are always nice if you have one you could post :slight_smile:

Thanks, Grant.

Well, the was/is great in Manual mode.

Now I just tried Auto mode and the Rover just spins like a top.

So, I need to research this new issue.