Rover Spins in Auto Mode


I am working on a project for my senior design using a Rover and the Pixhawk 4 flight controller on Mission Planner. We have gotten Manual Mode to work perfectly in Skid Steering mode and are now trying to run the rover in auto mode but there are a few issues:

  1. The rover continues spinning when Auto mode is first initialized but when we turn on manual mode and then back to auto, it goes straight but the wrong direction from the waypoint.

  2. The GPS isn’t the greatest and the rover managed to complete one mission out of the dozens we tried but was about 2m away from the waypoint (I had it to be 1m away just to test it out and see how close).

Is there anyway that this issue could be solved? I was even getting 18 sats in our local park today to test with and it managed to only work one single time.

Here’s some Bin files from the trials:

Please read the documentation and follow the tuning process:

Do not reverse RC channels to make manual mode work. Rather, reverse servo directions to match the default RC output.


I had problems with all this and Randy solved them time ago.

1 Like

I fixed it finally and now during the motor test both wheels move the same direction. The only problem I have is whenever I arm the vehicle, the left motor spins by itself even during manual operation. Is there a way to fix this in the parameters?

So I figured that reversing the servo output would mess with manual mode and when I set it to auto mode, the left motor is automatically set to Max PWM output. Is there a way where I can still have it reversed but keep the PWM to min so it does not move on its own when it’s armed (not set to auto)?

Reverse the associated RC channel for manual control.

The correct methodology is to set servo direction as it needs to be for assisted modes (like auto) and set the RC channels to output as appropriate once motor direction is correct.

I guess I forgot to mention that I am using Brushed With Relay with external motor drivers so when I tried what you did, I could not use the rover in the Armed state since the left wheel was running at high PWMs due to being reversed. I fixed this from the post that @Webillo said and it mentioned to reverse the motor outputs on the motor driver and that did the trick. I have also done the motor tests and they now both spin forward and backwards together. I also switched my pilot_steer_type for manual mode and am using the two paddle input instead of the default mode for skid steering due to the left side being reversed and causing it to spin the opposite way of the right wheel.