Servers by jDrones

Rover: Sonar data not present in telemetry data (always zero)

Hello,
I have a Pixhawk 2.1, ECT400, Mission Planner 1.3.72, ArduRover V3.4.2,
Windows 10. I did all the setup according to the documentation. When I
connect the ECT400 to my PC, it works. However, when I connect it to Pixhawk,
Mission Planner shows sonar range = 0 and sonar voltage = 0. I have a
Sparkfun rs232 to serial converter, it looks OK. I tried to examine it with
an oscilloscope, ECT400 definitely sending some messages. What could be the
problem?
Thank you and best regards,
Katarina
@rmackay9

Hi, Have you set all the parameters on the Pixhawk which are mentioned here.

https://ardupilot.org/copter/docs/common-echologger-ect400.html

Hello, yes, I did. At the moment, I can decode all the messages with an Arduino Mega (converter and echo are okay), but not with Pixhawk. I even tried different versions of ArduRover and Mission Planner with no results…

Make sure:

  • You have not accidentally reverse the RX and TX lines to the pixhawk
  • You’ve correctly set which port it’s connected to in Mission Planner (SERIAL2,3,4 etc)
Servers by jDrones