Servers by jDrones

Rover slows when he came to wp using Mission Planner

Hello,

I want to improve how mi rover work. It is big, E 1:1. I am using mission planner. I think that maybe is not planned to use it with so big rover.

I have a problem with wp. Each time he arrives or came closer to a wp he suddenly slow. I know that is because he starts planning how he can go to next wp. I don’t know if it’s possible to do it faster changing some parameter or something.

I’m using rwp=0.2, but I can’t make it bigger because I need precision.

I don’t mind when he go ahead, but doing some curves is so slow… I need better.

Thanks for your help.

It would probably help people provide better advice if you posted a video of your rover in action.
@Tractor_Pilot has a reasonably large rover which moves at a pretty good speed. How does your rover’s speed compare with the one shown in this linked video? (You can see a turn at time marker 2:30.)

Hi, just FYI I have uploaded a video of some testing I was doing yesterday. The original video that I posted about 3 years ago was of my very first attempts of ardurover but I never got the configuration right and it was using the Sabretooth to do the mixing. I’ve just upgraded to a Cube Orange and have finally got the configuration sorted with the mixing done by the autopilot.

Kind Regards,

Stephen

2 Likes

Sorry, i can’t show images of the rover.

It’t 1.5x2x3 m. Is like a small tractor. His speed is 5km/h. I think that is more or less same speed that i have see in the video. The wp radius is 0.2

Your issue is nothing to do with Mission Planner but rather your configuration. We have very large rovers (some over 3 tonne) and have no issues with MP. It has been a while since I have played with this tuning but I believe the behaviour you are seeing is caused by the navigation controller attempting to stay within the ATC_TURN_MAX_G and WP_OVERSHOOT parameters. You can play with these settings to get behaviour closer to what you want in turns but this may compromise straight line behaviour. You can also use WP_SPEED_MIN to set the minimum target speed allowable during a mission.

Thank you for the information. I’ll pley with this parameter. I’ll tell the result for others users.

Thanks

Servers by jDrones