Rover setup questions?

I am about to embark on a little rover build just for fun. I have printed this mini rover with a few modifications, and plan on using a pixracer. My one main question is do I have to also get a motor driver or will 2 simple brushed esc work to control the brushed motors that I plan on using. I have read through the wiki but still had that question. I plan on using these motors but still need a small ESC that would support up to 4s battery.

The fella that built this used this ESC but I am a bit skeptical about it.

I suspect the MicroRC 5A brushed motor ESC linked will work.

The output from the pixracer is normally PWM in the range of 1ms to 2ms (aka 1000 pwm to 2000 pwm). I looks to me like the ESC can probably accept this signal.

@Matt_C, Yes, I think these ESCs would use MOT_PWM_TYPE of 0 (Normal).

@Matt_C,

Thanks for the report.

We don’t actually support calibrating the ESCs in Rover so I’ve added it to our to-do list. My guess is that MP is showing the ESC calibration even though Rover doesn’t support it (it does work for Copter).

Nice rover.

I can imagine a few possible causes:

  • the output pwm range from the pixracer isn’t the same as the receiver’s output range. The way to fix this is to set the SERVOx_MIN and SERVOx_MAX (where x is the output channel connected to the motors) to match the RCy_MIN and RCy_MAX (where y is the input channel for the throttle from the receiver).
  • maybe there’s no PWM output coming out the back of the pixracer. This could be because the safety switch is enabled (disable by setting BRD_SAFETY_ENABLE = 0), the vehicle is disarmed or it’s in Hold mode (try manual mode)

Hope this helps

There’s no particular reason to disable the safety switch - I was thinking that perhaps on such a small rover there was no room but the parameter might have been left at BRD_SAFETY_ENABLE = 1. … The Copter experience should serve you well with Rover for the most part… although Rover is missing some features that Copter has they are coming together quickly.

@Matt_C,

By the way, in case it’s not clear, it isn’t necessary to use two-paddle-input on a skid-steering vehicle - I actually recommend sticking with the more traditional steering and throttle input. Some users get confused with inputs-and-outputs thinking they are somehow connected… but they’re really not.

To dig in further, if you can provide a dataflash log I might be able to see the problem.

I guess the motor is meant as a replacement part. Those motors are usually sold/bought together with a gearbox. I has a quick look with google and could not find a gearbox without motor.

Matt,

It should be possible to use the more common separated steering and throttle input by simply setting pilot-steer-type = 0 and then I suppose there may be some changes on the transmitter side in case you want to get both steering and throttle on the same stick… but from an AP point of view, there shouldn’t be any other changes required.

How do you like Uavcast? I’m thinking of trying it. try to post a short log. Power up, use the rover for 10 or 15 minutes, then power down. The log should be of a reasonable length.

I run a boat and this would be very useful.

What modem are you using? I have everything ( Pi3B+, Pixhawk 1, Pi cam ) except the modem and I am not sure what would be best.

Thanks… I’m in Florida and use Verizon. Is the high link important.

Good afternoon!
I have apm 2.6 and the mission planer program. At installation of an insertion of Rover the program gives an error message (Please Update - Some order library dlls are causing problems Method not found: Void Mission Planer.Arduino.Comms.set_StopBits (Svstem.I.O.Ports.StudBits)
I have three computers and everywhere the same mistake. Please help!

Just an update. I’ve got UAVcast set up on my Pi3b+. Just using the Pi’s WiFi on serial 0 for telemetry and the video is great on mission planner. Next step is setting up Zerotier and waiting for my Huawei Cell dongle to arrive. Thanks for giving me some confidence with the UAVcast system :slight_smile: @rmackay9 also. @Matt_C

1 Like

Really my only question at this point is how are you powering the Pi. I was going to use a castle 10 amp BEC. Plenty of Amps but I saw something on UAVmatrix about soldering wires directly to the USB connection for the modem. Is running a good supply to the power input on the Pi enough or is it really necessary to solder wires directly to the port the modem is plugged into? trial and error will tell me but looking for your input on your setup.

O.K… I figure I will give it a good power supply to its input and see what it does during extensive bench testing. Thanks again!!

@111165, this looks like a mission planner installation issue so maybe try re-installing it. It may also be that MP isn’t working properly on older versions of Windows (i.e. Windows7) but that is just a guess. By the way, the APM flight controllers aren’t officially supported anymore and the firmware for those boards is very old so we highly recommend upgrading to one of the more modern flight controllers listed here.

Great to hear that UAVCast is working for people. I might create a wiki page for it although I haven’t tried it myself yet.

I did not see any problems with the Pi, for video and telemetry, just connected via WiFi to my home network. I’m getting ready to tackle the cell part shortly. I think i’m going to try using an old MiFi hotspot first. I got my Huawei stick modem yesterday and managed to get myself locked out of the sim card from my hotspot somehow. I have a new sim card now (1 hour wasted at Verizon), in the “jetpack”, It seems they call them this now, and will play around a bit. I’ve watched the Zerotier video a 1/2 dozen times and I am still a bit confused but I’ll figure it out hopefully.