Servers by jDrones

Rover set-up in mission planner 2


(janssens) #1

how do I configure rover as a flight type in Mission planner 2 using a MacBook Pro latest version?


(Dave) #2

You need to Install the Rover firmware on your Flight Controller. Initial Setup>Install Firmware


(janssens) #3

Thanks for this feedback. Thera are a few problems with Pixhawk and MacBook Pro.
I tried first to set-up Pixhawk with QGroundControl. For some reason Rover set-up doesn’t appear when the latest firmware is installed. I then tried Mission planner which I finally got working with Pixhawk but this only works for copters and drones. I can select Rover type and flash the firmware but it does not connect to Pixhawk. To get Mission planner working with Pixhawk on MacBook Pro I followed the following tutorial: https://www.youtube.com/watch?v=wLK2wLwEXm4. Any idea how I can install rover on Pixhawk using MacBook Pro ?


(Dave) #4

QGroundControl should work to flash Rover. I just tried it on a bench Pixhawk I have and it worked. It loaded the current stable 3.4.2 (Nuttx version).


(James Pattison) #5

If you’re using a Pixhawk4 you’ll need to load a beta firmware, as Rover hasn’t had a stable release for Pixhawk4 yet.