Servers by jDrones

Rover not turning left in Steering Mode

Hello All,
I have a 3D printed tank running ArduRover 3.5.1 with an AUAV-X2.


In Steering- and Auto-mode the tank turns only very litte to the left, even with RC-stick full left. Steering to the right works well.
With centered RC-stick the tank does not go straight, already turns right.
I think the steering controller is tuned OK so far, although the PID values are quite small. Compass seems to be OK.

In Manual- and Acro-Mode the tank drives straight.

Does anybody have an idea why the tank has a problem to turn left in Steering/Auto mode?

Log: https://c.web.de/@337861202954682728/9ynuRiyyTgyT-IIY1haZ_A
Params: 20190622-Tank.param (13.4 KB)

The same thing happens with a different rover, also ArduRover 3.5.1
OpenRC Tractor https://www.thingiverse.com/thing:1967086
Equipped with a Omnibus Nano V6.
I have no logs for the tractor.

Thanks in advance for your help!

1 Like

Hi @RainFly,

I don’t see anything immediately wrong. The turn rate controller seems to be performing pretty well actually. I wonder if it might be the transmitter… I see that ARMING_CHECK = 0 and the RC input hasn’t been calibrated.

I think it might be good to turn back on arming checks (i.e. ARMING_CHECK = 1) and do the RC calibration. Sorry, I know that arming checks can be annoying but often they catch problems and then give a short description of the issue.

Thank you Randy!
I activated ARMING_CHECK and made RC calibration.
I use a Spektrum satellite receiver.
But rover still doesn’t turn well to the left.

It is strange, that in Auto- and Steering mode PIDDESIRED is already very small to the left. About half the value compared to right turns.
It looks like the rate controller doesn’t request a left turn.

Also strange, that I have the same problem with two completely different rover: Tank and Tractor.

btw. This is the funny Tractor:


1 Like

Rainer, could you try Acro and Manual modes to see if they also suffer from an inability to turn left well?

Hello Randy,
Acro- and Manual-mode work perfect.
Symmetrical turn rate and visible deflection of the wheels to the left and right.

The attached BIN-Log above was a short drive in steering mode. Full left, right and straight, as you can see in the “SteerIn” graph:

The corresponding “SteerOut” graph has an offset, which I can’t explain.

Very odd but I’m sure there is a good explanation…

The flight controller is mounted horizontally on the frame and pointing forward? The vehicle’s heading looks ok when looking at the GCS map?

Sorry, I’m away from my computer at the moment so I can’t analyse the logs immediately but I will later.

Hello Randy,

The Tank from the attached BIN-Log:
AUAV-X2 (1st generation) is rotated 270 deg. AHRS_ORIENTATION 6 (Yaw 270)
Only AUAV-X2 internal compass used, but seems to work OK.

The Tractor (no BIN-Log, but the same problem)
Omnibus Nano V6 mounted vertical AHRS_ORIENTATION 29 (Roll 180 Pitch 90)

Compass looks good for both of them. No Compass error messages in Mission Planner.
Heading looks good in Mission Planner.

btw: Rover 3.5.1 still suffers on sporatic parameter reset on Omnibus Nano V6 board.

With rover 3.5.1 I increased “Steering control Angel P gain” (ATC_STR_ANG_P) to 6.0 and reduced “Steering Rate P/I” accordingly.
Worked much better, but somtimes still wide left turns in auto mode.

Tried rover-4.0.0-rc1. Much better! Worked as expected so far.
So for me this issue is solved with rover-4.0.0.

1 Like

@RainFly, OK, great that 4.0.0 is working better although as far as I know we haven’t changed much in this area. Perhaps there are some lower level board changes related ot the Omnibus Nano V6 board that explain the change

Servers by jDrones