Rover not steering in AUTO mode

Hello Everyone,
Acutally, I am using mission planner 1.3.44 and I have ArduPilot 2.5. I can steer the rover in the manual mode. When I switch to the AUTO mode it still runs however, it doesn’t steer. The AHRS_GPS_USE is enabled.

Is it a GPS problem? my GPS is showing negative altitude which is not normal.
Please reply…

When you say it doesn’t steer do you mean it just drives in a straight line? Can you attach a log file when the issue occurs please?

Thanks, Grant.

1 Like

Thanks for your reply.
I have attached the t-log. Hope it helps.
2017-03-10 16-02-11.tlog (1.2 MB)
Please reply. It will be appreciated.

In the log file you attached you only go into AUTO twice. For 1 second and again for 7 seconds. During the 7 second run I can see the servo output trying to steer your Rover so it looks like its working.

You have SPEED_TURN_GAIN set to 1. That means it will apply 1% of CRUISE_THROTTLE (which you have set to 50%) when turning a corner and you have SPEED_TURN_DIST set to 2 meters away from the waypoint. Put SPEED_TURN_GAIN back to 100 and try again.

Your FS_THR_VALUE is 980 however your RC3_MIN value is 900. This means when your throttle is at minimum on your transmitter (I assume you have calibrated the transmitter as the min and max values have changed) your Rover will be in constant failsafe mode and as you have FS_ACTION set to 2 (the default) it will always go into HOLD mode. Lower FS_THR_VALUE to less then 900 - try 850.

Let us know how you go.

Thanks, Grant.

Thank you very much @gmorph…Now, the problem is that I am getting the “BAD GYRO HEALTH” problem. I am failing the accel calibration everytime. Earlier it was not happening. I am unable to fix it. My rover is moving forward and steering. However, it is wandering while steering. Do you think it is because of bad gyro health? Is there any particular parameter that I can look for in tlog or full parameter list? I have also tried to re-install the firmware and upload it again as someone suggested that it might fix it. But it didn’t.

I have made some changes with the parameters. Also, I couldn’t lower the FS_THR_VALUE to 850 as the range was from 925-1000.
I have again added the tlog file.
2017-03-13 16-00-46.tlog (861.2 KB)

In the log you have CRUISE_THROTTLE set to 1. That’s 1% of your total throttle. And you have CRUISE_SPEED set to 10 which is 10m/s. So its unlikely your rover is going to do 10m/s at 1% throttle unless you have a jet powered rover.

Your GYRO does appear to be mis-behaving. Its all over the place when the rover should be stationary in HOLD mode. See the graph below. In fact your compass and accel are also bad. I assume when the rover is in HOLD mode its rock still and not moving? If that’s the case either you have shocking vibration or your IMU is broken.