Rover not following all waypoints

I am having trouble making the rover follow a mission. I had quite a few successful missions, but now the rover is behaving unexpectedly.

I had a 3 waypoint mission and after reaching the 2nd waypoint the rover starts to come towards home. I am not able to figure out why. Any help would be appreciated.

Have you updated the ArduRover2 firmware since running your successful missions?
I would carefully review your mission waypoints to make sure that there is not an unnoticed RTL command in the mission sequence.
What is your waypoint radius parameter set to?
How far is your third waypoint from the second waypoint? If the third waypoint is too close to the second waypoint it may think that it has completed the mission.
You might want to flush the present mission and start fresh.
Also what do you have the MIS_RESTART parameter set to?


Yes I have updated the code. The problem persists.
I have checked, I had set the RTL on the 3rd waypoint and the 2nd and 3rd waypoints were quite far off.

Am sorry for I am quite new to the apm community, I do not know how to check the value of the parameters.
From the mission planner UI though, which gives an option to restart the mission under the actions tab I tried restarting the mission. It did not help and it would still come back to home from 2nd waypoint.


I do not know how to help you out here as I have always had my last waypoint end just beyond the starting waypoint in a closed circuit mission. I have never tried to use RTL at the last waypoint.
The mission waypoints are stored as a text file that can be saved and loaded at will. Put your mouse pointer on the map tile and right click on the map tile and you will see a list of functions that you can initiate.
Also, at the bottom of the map tile you can make the waypoint data become visible by clicking on the up arrow on the right side of the tile at the bottom.