Servers by jDrones

Rover going crazy in lightspeed circles in Simulator

(Robert Driller) #1

Hi, i am using the simvehicle.py from the latest git pull of ardupilot.
I wanted to test the controll mechanisms of a custom software via mavproxy. It behaved with very extreme movements. Now I tested using the built in “fly here” commands and also get the lightspeed circular movement there. I attached the log. maybe someone can help me.
I already set speed parameters very low so i do not see hot it could spin that fast.

Anybody got an idea?

(rmackay9) #2

@Robert_Driller,

Sounds like some changes have been made to the parameters. I’d recommend removing the eeprom.bin file and trying again. The default parameters that SITL starts up with can certainly control the virtual vehicle pretty well in all modes including Acro, Guided, Auto.

(Robert Driller) #3

Thanks for the Tip, I already tried that but I always end up with the same result.

Just now I did a complete fresh git pull and submodule update so I have a reset on the simulator and started it with rover.param (which i merged with rover_skid.parm).
With that I starte my programm.
Basically my programm lets me enter MAV_FRAME_LOCAL_NED position changes in and sends them with 10hz update rate (I also tried what happens when I only send it once, same result).

The Result is the same again, the rover goes loco when it needs to perform a curve.

(rmackay9) #4

I can’t really help with your program but I can confirm that SITL seems to be working. When I start SITL doing this:

  • cd APMrover2
  • …/Tools/autotest/sim_vehicle.py --map --console

Then wait a bit for it to start and then:

  • acro
  • arm throttle
  • rc 3 1800
  • rc 1 1450

and the vehicle drives a relatively wide counter-clockwise circle.