Rover "Follow Me" mode in qgroundcontrol

I recently finished putting together a rover and have things working mostly ok aside from follow me mode in QGC. I dont see the option on the app, and the switch I have assigned to it just says “unknown flight mode” when I set it to follow. I have enabled the follow parameter.

Am I missing a setting or using the wrong app?

For anyone trying to find an answer to this like me…it appears qgroundcontrol doesn’t support “follow me” with ardupilot or PX4 at the moment.

I have ordered a Bluetooth GPS and will be looking for a simple configuration on missionplanner that can be a little more portable.