Rover Firmware Issue

I cannot get my PixHawk working with the ArduRover 3.0.1 firmware. I tried with the Quadcopter firmware and and was successful in arming so I know it is not a hardware issue. I cannot get it working in QGroundControl or APM Planner 2.0, I just receive double yellow blinking lights on my main LED even though all the sensors say they have been calibrated properly.

Something seems to be glitching with flight modes. My Safety parameters are also blank. I get the following errors:

vs. it working properly with the Copter 3.3.3 Firmware:

Any suggestions? Been stuck on initial calibration for about a week now.

Have you tried using Mission Planner (not APM Planner)?

Yes, have tried in all three ground stations. As well as different Pixhawks and GPS units to make sure it wasn’t a hardware error. I’ve gotten it to work with the Quadcopter firmware so I’m hoping I can reproduce the results with the Rover firmware but I am having no luck.

It looks like QGroundControl isn’t working correctly with the rover firmware - I’ll chat to the QGC team to see if we can get that resolved.
It should work in MP though. Can you attach a log file please?
Thanks, Grant.

I spoke with Don Gagne the QGC developer who has quickly and expertly made these fixes

to get Rover working well with QGC. It should be available in a new daily build in the next few hours.

Thanks, Grant.

Nice work Grant, much appreciated.

How do I update QGC on my mac with the new edits? I’m pretty new to github

Nevermind, I see you can simply download and reinstall the program from the QGC Daily Builds page:

I will test today and let everyone know how it works out

I always delete the existing QGC on my computer before installing a newer version as it save a lot of grief later on.

Update worked well. I can now switch between modes from my transmitter instead of within QCG. Thanks for the quick update and reply!

Also for folks using Rover+QGC. Please make sure to let me know if there are still important things missing. I’m on QGC gitter channel almost all the time: We’ll try to make Rover even better in our 3.1 release. But want to make Rover is functioning at a decent level for our 3.0 release.

New update, got the Rover’s compass calibrated again and was able to run several missions.

Sometimes when switching to Auto mode i get the error “can’t verify conditon” but if I try again it runs fine. Also, condition is spelled wrong in the firmware. Also, I sometimes randomly get the error ‘Error Failsafe 0x1’; I’m not sure what this error means or what causes it because it never seems to effect anything.

I tried to run guided mode today with the Rover but I get an error message saying ‘Guided mode does not work with this firmware.’

Here is a log:

I’ll fix the spelling :slight_smile:
Is that the exact wording ‘Error Failsafe 0x1’ because I can’t find it anywhere in the code. 0x1 usually means an RC failsafe has been triggered (this is a guess as I can’t find the exact code). You have your Throttle FS set to 910 and the only place I see that in the log is right at the end when you appear to turn off your transmitter before powering down the pixhawk. Note you shouldn’t do this - always turn the transmitter off last after everything else. If you did go into FS you have it set to HOLD and your rover does go into HOLD a lot.
I assume the ‘Guided mode does not work with this firwmare’ message came from QGC in which case we need to get that fixed in there.

Thanks, Grant.

QGC doesn’t not currently support Guided mode for Rover. I’ll add that when I add the new Reverse support.

That’s great. Thanks Don!