Rover: ESC Help needed - ESC With Button: Configure

Hello, and thanks to everyone on here.

First time setting up Rover. (Ardupilot Rover 4.0 Mission Planner 1.3.74)
Pixhawk1 (2.4.8) , FrSky X9D with X8r receiver, and Hobbywing QuicRUN Brushed ESC.

I cannot find help or documentation on setting up a regular old RC car ESC. Almost all of these have an ON/OFF button, with a set button. (Not like your quadcopter ESCs)
The set button is traditionally how you setup the ESC. This is not conducive to the way you setup Ardupilot .

Can someone explain how to get Ardupilot to work with this type of ESC?


I really do not understand where the problem is. The setup button is not needed for normal operation of the ESC and the power switch/button can be activated by hand. Setup the ESC for forward/reverse operation, not forward/brake/reverse, connect it to the autopilot and do the rest of the ardurover setup.

Really - which ESC are you using…?
I have tried everything. My pixhawk1 (2.4.8) works great so far with the setup as advertised, but when it comes to “This ESC” - The ESC just sits there and blinks. I have tried everything… Right now, I am getting ready to attach an OLD traxas ESC that I borrowed.

What ESC is working for you - any tips would be great. Thanks

I used a bunch of different car, airplane, multicopter and robot ESCs with and without switches/buttons. They all worked with different flightcontrollers/firmwares.
Things that I did to make an ESC not work with an autopilot were:
plugging the servo connector in the wrong Pixhawk output (Main1/Aux6), turning the servo connector around,
using an extension cable and then turn the connector around, having two ESC with a power push button influencing each other (one button switched both ESCs on/off) and certainly others I forgot about.

Right now my rovers use cheap amazon brushed ESCs, Flipsky VESC 4.12 (VESCs are the best I ever used), Sabertooth 2x12 and blheli.

Thanks so much for your reply.!!! That is great news !
That must be why there is little documentation on this process is because it’s usually so easy and flawless…

I have definitely checked the wiring multiple times.
I am ordering this today:

Things I am thinking might be affecting my setup are:

– Maybe the PWM signal coming from the Pixhawk is not 1500us when I turn on the ESC.
– The version of software of firmware I am using is not compatible. I am using Rover 4.0 (i believe), and pixhawk 1 (2.4.8)
– Maybe the 5 volt line from the ESC has to be tied to the servo rail (I get the Zenner Diode today).

Something odd is happening(sometimes), because when I turn on the ESC - The wheels immediately turn to the right (the servo is plugged into pin 1) and the steering still responds to the transmitter for steering. This only happens sometimes, like if I turn on the ESC before using the safety switch (button thing)…

I don’t know if it matters when I turn on the ESC…

Ok, I got it working. I will be posting a video of the solution, but here is the jest.

When calibrating the joysticks - At the end of the calibration Mission Planner pops up a message that says “Put throttle all the way down then press OK” alright, that makes sense right… For someone who is brand new, and never done this, and just following directions - That is what I did. I do not believe that is correct. - - - FOR A ROVER.
Leave the joystick in the center 1500us position…

When I was monitoring what the pixhawk was sending out of CH3 I would see 1500us until I would arm the vehicle, then - even though I have not moved the throttle, the pixhawk would send 1650-1750us… This was the issue. Once I recalibrated the joysticks, and left the throttle center upon completion - the ESC worked fine. and the output for CH3 matched what was being sent by the transmitter.

Thanks for you alls help.

You should use a spring loaded stick as the throttle input for ardurover. Switch throttle and pitch in the mixer settings in your Taranis.

Or a reverse switch on the radio with low stick as neutral. Admittedly not common but this strategy seems more intuitive to me. Kind of like how a real car is driven.

@count74 I agree - I switched my Taranis X9D Transmitter to using the Elevator as the Throttle - Thanks.
@dkemxr - I like that Idea… That would be very easy to do as well. Plus it could allow more precision and PWM bandwith… That is a really cool idea.

AND for those reading this thread that need help with Taranis X9D Inputs vs Mixer -
I use the Mixer Menu for all my assignments. Ironically - It can also be done in the Inputs menu - but that can be confusing. I recommend:

Regarding @dkemxr Dave’s idea, I have a few concerns. First would be accidently bumping the throttle. With a spring loaded stick, the rover would make a short jump and stop again. With a sticky throttle the rover takes off and you will have to grab the stick and pull it down or disarm the rover.
Another thing, with a spring loaded throttle, it is always clear which direction is which. With a sticky throttle, you will have to check the reverse switch or program a warning, so you do not drive in the wrong direction by accident. I would not like my 15kg rover to start backwards while I am standing behind it.

1 Like

All valid concerns. I haven’t realized those, my biggest worry is to hit the fwd/reverse switch while throttled up slamming into the opposite direction. I could mix in a low throttle limit so it can’t do that I suppose.

1 Like