Rover brushed esc setup questions

I’m setting up a tracked rover with a kakute F4 V2
I’m a bit lost with getting the motors to work.

Left and right track both have their own motor and brushed esc (from an rc car)

What are the steps to follow to get them to work in arduoilot setup.
The board works, GPS works, transmitter works.
In the transmitter page the stick outputs work.
I setup an arm switch.

Left motor esc is connected to motor1 and the right motor esc is connected to motor3 on the board.
I don’t use the 5 volt wire from the esc since the esc’s are powered seperatley by their own battery that powers the motor.
So I only use the signal wire (and also connected the ground wire to the PDB)

Motor test does nothing.
I have servo output 1 set to throttleLeft and servo 3 set to throttleRight.
Is it normal that I don’t see any servo output when I move the sticks like you so in the transmitter setup page?

Help, seemed to have tried al I think there is to try.


Can the vehicle be armed using either the transmitter or the Arm/Disarm button on the ground station? If not then this could cause the motor test to fail. In either case if it can’t be armed then the reason is normally displayed on the groundstation. If using Mission Planner it will appear on the HUD or in the “Messages” tab on the Flight Data screen’s lower left.

I can ARM and disarm the Rover with a switch on the transmitter.
When I arm it says ARMED on the ground station.
I disable the GPS check in case it will not arm because it cannot find enough satellites.

Check if you have BRD_Safety = 1.
This enables the hardware safety switch, which your FC does not support/have.

Probably best to download a dataflash log and post it here…

Where can I find BRD_Safety? Did a seach in all the parameters and cannot find it.
I did notice that the servo output shows some sign of life when the rover is armed.
Since I’m using brished esc’s that just take a PWM signal I thought it was idea to connect a servo to M1 to see if that works, but no movement. Don’t know if it is possible to test the output this way.
I’m still unsure about the kakute F4.
I’ll make a dataflash log.

1 Like

My guess is that the BRD_SAFETY parameter doesn’t exist in the firmware for the Kakute boards because they can never have one. The dataflash log will be good for us to look at.


erhm… when I go to flight data the log list is empty so cannot download a log there.
When I go to terminal and then to log window this is what it looks like?? what’s this jibberjabber?

wait, I got something :slight_smile:

Which file do you need? I see it save several files (bin, log, kmz, gpx etc)

@OldRaven, the .bin files are the best ones.

Sorry for the delay, have a bit of a fight with the FC.
Not sure if I want to put more time into the kakute F4 for this and just move to a pixhawk to eliminate all the guesswork.
It seems like it dumped a lot of files and just cannot figure which file I need to send.

Forget the terminal, use the “download logs via Mavlink” button from the Dataflash Logs tab. You say there are no logs listed? What is the LOG_BITMASK and LOG_BACKEND_TYPE parameters set to? No sdcard on that FC right?


LOG_BITMASK is set to 65535
LOG_BACKEND_TYPE is set to 4

attached is the bin file when I do a download logs via mavlink.

The kakute F4 does not have an sdcard.

That is one of the reasons I think I might be better off getting another flightcontroller for this test.

The idea is to build a Rover platform that can carry some custom equipment to do measurements on farmland autonomous.1 1-1-1970 1-00-00 AM.bin (256 Bytes)

Those settings are OK and clearly you have .bin logs but there is nothing in that log file. A parameter file can’t even be created from it which has the most value at this point. Just post the parameter file, maybe something can be learned from that.