Rover acting as copter (ESC related ?)

Hello everyone, first post here ! So if I did wrong, feel free to tell me !

So I’m trying to set up a rover with ardurover 4.0 on a cube black, but I can’t get things to work properly.
I’m using Mission Planner, and have set up those parameters for tests purposes :


I then plugged my ESC (FPV 30A-32bit 2-4S from T-Motor) on the 3rd servo rail output of my carrier board, wired to a Velox motor.
I’m using a Futaba R7008SB receiver and a T14SG RC, and I have already reversed Throttle and Pitch.

So here is what happens :
When I power the cube, I can connect properly to Mission Planner and arm my proto. Then, when I power my ESC, it ALWAYS enters calibration mode, whatever my throttle stick position is. I tried to callibrate it properly, but it never “saves” it (I tried with two different ESCs). Even stranger, when I finish calibration (with my throttle stick at minimum), my motor then act as if it was a copter, not spinning when throttle is at 0 and spinning very, very fast when throttle is at maximum. But I think since I’m running ardurover, motors shouldn’t spin when throttle stick is centered, should spin backward if throttle is low and forward if throttle is high right ?

Please tell me if I misunderstood how ardurover is supposed to work, and if I didn’t, any help will be greatly appreciated !
Thanks !

Your ESC has to support bidirectional operation to fully work with Ardurover. RC car ESCs do, BLheli ESCs can be configured for bidirectional mode. The ESCs manual should tell you more.
Ardurover sends 1500us PWM signal per default. This might be high enough to cause your ESC to enter setup mode.

Thanks, I just tried to connect my ESC to BLHeliSuite32 to check all of that. The only problem I face is that for rovers, I can’t find the SERVO_BLH_AUTO parameter. It is here for copters, but not for rovers. After some research, it seems needed to be able to connect to BLHeliSuite32. Do I need to set up my ESC with a board with ArduCopter ?

UP : I installed arducopter on my cube and managed to connect to BLHeliSuite32, but then an error message appear when I try to click on check : No valid ESC configuration Found. Any help will be welcomed

Post the parameter file.

Here it is !
copter_connection_blheli.param (16.6 KB)

And here is what happens when I click “check” on blhelisuite32 :

And when I test my motor in the Motors tab, it’s spinning correctly

So the motor is connected to the Aux 1 output?

I think it is yes, please see the attached image for confirmation :

I don’t know where the outputs are on Cube Black carrier but you have SERVO9_FUNCTION as motor 1 (33) which would be Aux channel 1. The main outputs on a Cube do not support Dshot so that would be the right way to do it.

Ok thanks, I have a carrier board mini, so I don’t have access to the aux channels… I’m wired to the main output actually. That’s probably why it doesn’t work properly. But it’s weird that i can spin the motor in the test tab still :thinking:
Thanks a lot for your help, I’ll try to get myself a normal carrier board !

That doesn’t sound right. Looks like they are here:


Oh my bad I didn’t saw that, I’m reading too quickly. Thank you again. I’ll try that tomorrow !

It finally worked ! Thanks a lot to everyone who helped !