Rover-4.4.0-beta8 release

Rover-4.4.0-beta8 has been released and can be installed using MP or QGC’s beta firmwares links or the appropriate binary for your autopilot can be downloaded from

The changes vs -beta7 are in the releases-notes and copied below.

  1. Autopilot related enhancements and fixes
    • BETAFPV-F405 support
    • MambaF405v2 battery and serial setup corrected
    • mRo Control Zero OEM H7 bdshot support
    • SpeedyBee-F405-Wing gets VTX power control
    • SpeedyBee-F405-Mini support
    • T-Motor H743 Mini support
  2. EKF3 supports baroless boards
  3. GPS-for-yaw allows base GPS to update at only 3Hz
  4. INA battery monitor supports config of shunt resistor used (see BATTx_SHUNT)
  5. Log VER message includes vehicle type
  6. OpenDroneId option to auto-store IDs in persistent flash
  7. RC SBUS protection against invalid data in first 4 channels
  8. Bug fixes
    • BMI088 IMU error value handling fixed to avoid occasional negative spike
    • Dev environment CI autotest stability improvements
    • OSD correct DisplayPort BF MSP symbols
    • OSD option to correct direction arrows for BF font set
    • Sensor status reporting to GCS fixed for baroless boards

Any and all feeback is greatly appreciated!


Installed beta8.
RCINScaled still needed midpoint set to the minimum value, else wrong action.

Throttle in Mode Acro still not possible to get zero motion. Not in Stick Middleposition nor Stick back.
At Stick back it first moves backwards, then reverse and go forwards.

With this issue all the new features are not usefull for me. According to the Wiki, Acro is a basic function.
In Mode Manual all functions works perfect. And Tuning Speed and Throttle as demonstrated by Tridge succesful. (Even better as demonstrated :wink:)
What do I wrong?
Link to Log

@rmackay9 May be you couldn’t reproduce the reported issue.
I found a relation with the issue I reported first.
When in Setup/Servos the Trim is set to the usual Value 1500, then the min. Value can’t be reached.
Therefore I set the Trim for Output 3 to the min. And so I could control the motor in Mode Manual from max. Reverse to max. Forward.
But the it produces crazy outputs in Mode Acro.

After setting the Trim to 1500, The motor can be controlled in both Modes from 0 to max. Forward
But no more drive Backwards is possible neither in Manual nor Acro.

I tested it also with FW V 4.2.3 official, but also no succes.
I tried to show it here.

Hi @Lorbass1,

Re the inability to reverse, I think the RC3_TRIM value is set incorrectly. It is currently set to the same value as RC3_MIN (e.g. 995) but normally it should be close to the average value of RC3_MIN and RC3_MAX.

It looks like ARMING_CHECK = 0 so all the arming checks are disabled. If left enabled I think an arming check would have alerted you to this issue. In general it is best to leave ARMING_CHECK=1 and then investigate and resolve any issues displayed. Worst case you may disable a single arming check but disabling them all is almost always a bad idea.

Relative to Beta8 my trials find it to perform well. No surprise I suppose as the changes wouldn’t effect my component group.

Thanks for the answer.
In the first diagram the RC3_Trim ist set to 1500, min=1000, max=2000
And with this in Manual and Acro it works to control with Servo3_Out = 1500 up to 2000 only.
Reverse would be from 1500 down to 1000.

When Trim ist set close to Min. then Manual works from 1000-0-2000 but Acro behave crazy.

I work now since 15 years with Arducopter or Arduplane VTOL and never had such strange behavior.
I disabled arming checks for indoor tests, but will make a trial to set it as recommended.

Set now the arming checks excl. GPS (Indoor)
RCOU_Trim 1500
MP-Messages below
No Output below 1500, means no Reverse even when RCIN3 at 900.
Log: 2023-10-16 18-12-49.bin - Google Drive

I was wondering if would be possible to use a Multicopte as a bathymetry platform.

…I built a boat carrying the Echologger echosounder. The idea now is carrying the sonar in a multicopter inspired by the following commercial drone:

Thinking about the current setup options in Ardupilot, I have some doubts that can resume in two big issues:

• Actually, only the Rover configuration allows to logger of the depth data, from sonar, in the variable DEPHT. I am not sure about that, but I haven’t found any reference to this feature in another version (taking into account that is necessary the FRAME_CLASS parameter should be set to “2” (Boat) in order to support sonar devices).

• In order to maintain a precise altitude over the water surface is necessary to use a rangefinder. But, despite of each can use a different serial port, both, sonar and lidar, have to use the serial “protocol” 9 (lidar), and RNGFNDX_ORIENT as 25. I don’t know if both can works in parallel without issue. Thinking that both show their value in the variable SONARRANGE, perhaps there exists some kind of issue to resolve.

I don’t know if it is within what is technically feasible, but it will spread the possibilities of thinking to hard-to-reach areas. I hope someone can help is this project.

Hi @Lorbass1,

I think the output throttle does go below 1500 at one point in Acro mode.

I noticed that ARMING_REQUIRED=0 which is quite unusual. Could you re-enable this please?

Also Acro mode requires the vehicle know its velocity and from a quick look it seems like the GPS quality is very bad.

The log was from an indoor test on the desk to see if in Manual with Trim 1500 reverse is possible.
Your pic shows backward drive when switching to Acro even with RCIN3 = 0.

Again a test on the desk inside with ARMING_REQUIRED=1.
Throttle reacts now normal in Acro, even on desk-stand.
But why do I send RCIN_C3 with Min. (PWM 041) to get RCOU_C3 = 1500 (Stop Motor)?
This means Reverse command can’t be given.

Beside this, now I must find the reason why I get a message Arming failed if in MP Hood is showed:
Ready to arm.(Just to inform you, but do not want to charge you about)
Log: 2023-10-17 08-46-57.bin - Google Drive

Will make a drive test outside.

Arming by Telecommand solved. But also here a difference to the manual.
The recommended left middle Stick Position works not. instead the lower Position. (Which is also
low Throttle, would make sense)
It seems there is an offset and a divider somewhere bewen Input and Output.

@rmackay9 No Test 10, outside. “Nearly” perfect, except drive backwards not possible.

Log: Test 10.bin - Google Drive


Hi @Lorbass1,

Great video! just love it.

I think the issue with not being able to reverse is that RC3_TRIM = RC3_MIN (941). So RC3_TRIM should be set to mid way between RC3_MIN and RC3_MAX so around 1500.

I guess maybe you’re using QGC with a joystick? I think there is an option in QGC to control whether zero throttle is at mid or minimum.

@rmackay9 Thanks for the praise. I tried to motivate and understand the Vehicle by People without knowlege of all the Data in the Log. Post processing takes 2 hours. Fortunatly it is possible to convert the Logdata with MP to .csv Format which is needed in Dashware.

But UPS, I have not checked the strange RC3_Trim. This must be set by the Radio Calibration Process.
To finish the calibration procedure it is recommended in MP to lower the Throttle stick.
I set it to 1500 and it works already indoor. Will test it later when better Wether.
Thank you verry mucht for your assistance. I lost nearly the last nerve.

I use this system with a Radiomaster TX as already for Copter and VTOLs.
To see the video, click on Youtube right, down. (After the start)
No Idea why this does not load in the forum.

In the air I had in a range of 2 km a good video an no signal loss. But now with all the laws and regulations it is to complicatewith an UAV so I changed to UTV. (Unmanned Terrestrial Vehicle :wink:)

1 Like

@rmackay9 Hello Randy, finally better Wether to make a Test again.

After your help everything work as it should. Here the feedback of the Test.
Log: Test 11.bin - Google Drive

One point a have to work on. The Rover has switchable gears. The speed control in Acro or Steering
hold the same max. Speed and so the faster gear produce the same Speed as the lower. (With less revolutions of the motor)

Thank you again for your help.

1 Like